summaryrefslogtreecommitdiff
path: root/tox.ini
diff options
context:
space:
mode:
authorTres Seaver <tseaver@palladion.com>2012-04-06 23:00:52 +0000
committerTres Seaver <tseaver@palladion.com>2012-04-06 23:00:52 +0000
commit72051b12b27f3f96a3e4c877eff715d4cec6b7fa (patch)
tree593c9a88281f825bc0fd45c7a4d555dacdbaceda /tox.ini
parent9d8595c0ded4395a6ef8a4aa8887d89faf506973 (diff)
downloadzope-i18nmessageid-72051b12b27f3f96a3e4c877eff715d4cec6b7fa.tar.gz
Bring into line with other tox.ini.
Diffstat (limited to 'tox.ini')
-rw-r--r--tox.ini20
1 files changed, 19 insertions, 1 deletions
diff --git a/tox.ini b/tox.ini
index eb62b24..2bd53e3 100644
--- a/tox.ini
+++ b/tox.ini
@@ -1,6 +1,9 @@
[tox]
envlist =
- py24,py25,py26,py27,py32,jython,pypy
+# Jython support pending 2.7 support, due 2012-07-15 or so. See:
+# http://fwierzbicki.blogspot.com/2012/03/adconion-to-fund-jython-27.html
+# py26,py27,py32,jython,pypy,coverage
+ py26,py27,py32,pypy
[testenv]
commands =
@@ -9,3 +12,18 @@ commands =
[testenv:jython]
commands =
jython setup.py test -q
+
+[testenv:coverage]
+basepython =
+ python2.6
+commands =
+# The installed version messes up nose's test discovery / coverage reporting
+# So, we uninstall that from the environment, and then install the editable
+# version, before running nosetests.
+ pip uninstall -y zope.i18nmessageid
+ pip install -e .
+ nosetests --with-xunit --with-xcoverage
+deps =
+ nose
+ coverage
+ nosexcover