summaryrefslogtreecommitdiff
path: root/tox.ini
diff options
context:
space:
mode:
authorChris McDonough <chrism@plope.com>2011-07-15 08:29:22 +0000
committerChris McDonough <chrism@plope.com>2011-07-15 08:29:22 +0000
commit5b50748f93b711d742284fcd0e1408744ce9060e (patch)
tree3cf741124c646b0193a6902cacfae60a8c7f4f79 /tox.ini
parentc16f15d4dd0356e1d8e3e686ae4829b4d236beb2 (diff)
downloadzope-i18nmessageid-5b50748f93b711d742284fcd0e1408744ce9060e.tar.gz
- Don't attempt to compile C extensions on PyPy or Jython.
- Add a tox.ini (see http://tox.readthedocs.org/en/latest/) for easier automated testing.
Diffstat (limited to 'tox.ini')
-rw-r--r--tox.ini11
1 files changed, 11 insertions, 0 deletions
diff --git a/tox.ini b/tox.ini
new file mode 100644
index 0000000..eb62b24
--- /dev/null
+++ b/tox.ini
@@ -0,0 +1,11 @@
+[tox]
+envlist =
+ py24,py25,py26,py27,py32,jython,pypy
+
+[testenv]
+commands =
+ python setup.py test -q
+
+[testenv:jython]
+commands =
+ jython setup.py test -q