summaryrefslogtreecommitdiff
path: root/tox.ini
diff options
context:
space:
mode:
authorJason Madden <jamadden@gmail.com>2017-05-01 16:35:14 -0500
committerJason Madden <jamadden@gmail.com>2017-05-01 16:43:06 -0500
commit5954f86733df49920427de4a931b23f8c5db9c95 (patch)
treed4816cc4a225c052e00de1da46f685d8607e2934 /tox.ini
parentceb5981168a9b5b6c07b307cdf7fa11c96bb8fc7 (diff)
downloadzope-i18nmessageid-5954f86733df49920427de4a931b23f8c5db9c95.tar.gz
Use C extension in Python 3, and make Python version handle ``default`` the sameissue4
Fixes #4 and fixes #5. Add a specific test case for both of these things. Enabling the C extension on Python 3 revealed more places where readonly attributes can raise different exceptions so fix those tests. Also add Python 3.6 to the supported list, and use zope.testrunner to workaround the namespace package issue.
Diffstat (limited to 'tox.ini')
-rw-r--r--tox.ini16
1 files changed, 10 insertions, 6 deletions
diff --git a/tox.ini b/tox.ini
index 3bf1484..0f644e3 100644
--- a/tox.ini
+++ b/tox.ini
@@ -1,16 +1,20 @@
[tox]
-envlist =
- py27,py33,py34,py35,pypy,pypy3,coverage,docs
+envlist =
+ py27,py33,py34,py35,py36,pypy,pypy3,coverage,docs
[testenv]
-commands =
- python setup.py -q test -q
+deps =
+ .[test]
+ zope.testrunner
+commands =
+ zope-testrunner --test-path=src []
+
[testenv:coverage]
usedevelop = true
basepython =
python2.7
-commands =
+commands =
nosetests --with-xunit --with-xcoverage
deps =
nose
@@ -20,7 +24,7 @@ deps =
[testenv:docs]
basepython =
python2.7
-commands =
+commands =
sphinx-build -b html -d docs/_build/doctrees docs docs/_build/html
sphinx-build -b doctest -d docs/_build/doctrees docs docs/_build/doctest
deps =