summaryrefslogtreecommitdiff
path: root/tox.ini
diff options
context:
space:
mode:
authorJason Madden <jamadden@gmail.com>2017-12-16 07:40:29 -0600
committerJason Madden <jamadden@gmail.com>2017-12-16 07:40:29 -0600
commit89927bff938e8d11cd7c8acd705e8ebef43b6b1c (patch)
tree8373c827aa50a555ab210d183ee10f80f0884db8 /tox.ini
parente924eea24f6d9b635a4b3370d90bb1ce7869b944 (diff)
downloadzope-i18n-89927bff938e8d11cd7c8acd705e8ebef43b6b1c.tar.gz
Remove _compat module and _u function in favor of native unicode literals and project gardeningdrop-33
- DRY with dependencies - Enable coveralls.io and add a coverage tox environment - A few tiny changes to increase coverage, but we're not at 100% - Enable testing sphinx docs for all versions - Publish CHANGES.rst on RTD - Modern tox.ini and .travis.yml - Travis was still testing 3.3 and not testing 3.6. - Remove 'level' qualifiers from XML parsing and ZCML test cases. They add about 2s to run the tests, but they're important; see #13. That extra time gets lost in the amount of time it takes to spin tox anyway.
Diffstat (limited to 'tox.ini')
-rw-r--r--tox.ini34
1 files changed, 10 insertions, 24 deletions
diff --git a/tox.ini b/tox.ini
index cd5b081..f9b40c5 100644
--- a/tox.ini
+++ b/tox.ini
@@ -1,32 +1,22 @@
[tox]
-envlist = py27,py34,py35,py36,pypy,pypy3,coverage,docs
+envlist =
+ py27,py34,py35,py36,pypy,pypy3,coverage,docs
[testenv]
-# We need to use develop egg to get namespace directories right.
-usedevelop = true
commands =
- python setup.py -q test -q
+ zope-testrunner --test-path=src []
+ sphinx-build -b doctest -d {envdir}/doctrees docs {envdir}/doctest
deps =
- python-gettext
- pytz
- zope.component
- zope.configuration
- zope.i18nmessageid
- zope.location
- zope.proxy
- zope.schema
- zope.security
- zope.testing
- zope.testrunner
+ .[test,docs,compile]
[testenv:coverage]
+usedevelop = true
basepython =
- python2.7
+ python3.6
commands =
- coverage erase
- coverage run --source=src setup.py -q test -q
- coverage report --show-missing
- coverage xml
+ coverage run -m zope.testrunner --test-path=src []
+ coverage run -a -m sphinx -b doctest -d {envdir}/.cache/doctrees docs {envdir}/.cache/doctest
+ coverage report --fail-under=97
deps =
{[testenv]deps}
coverage
@@ -36,7 +26,3 @@ basepython =
python2.7
commands =
sphinx-build -b html -d docs/_build/doctrees docs docs/_build/html
- sphinx-build -b doctest -d docs/_build/doctrees docs docs/_build/doctest
-deps =
- {[testenv]deps}
- Sphinx