summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJeremy Kolbe <jeremykolbe@posteo.net>2018-10-05 16:44:13 +0200
committerMichael Howitz <mh@gocept.com>2018-10-05 16:44:13 +0200
commita2087c134f765ba87efbc7059036f755af895e21 (patch)
treebb0815340947ef47642d298d40d53f3d2d00b7ac
parentece19b3b7d984657019a896bdc5e3b407f75ac9e (diff)
downloadzope-i18n-a2087c134f765ba87efbc7059036f755af895e21.tar.gz
Add support for Python 3.7 (#33)
-rw-r--r--.travis.yml5
-rw-r--r--CHANGES.rst2
-rw-r--r--setup.py1
-rw-r--r--tox.ini4
4 files changed, 9 insertions, 3 deletions
diff --git a/.travis.yml b/.travis.yml
index e770bda..b2ff47d 100644
--- a/.travis.yml
+++ b/.travis.yml
@@ -7,6 +7,11 @@ python:
- 3.6
- pypy
- pypy3
+matrix:
+ include:
+ - python: "3.7"
+ dist: xenial
+ sudo: true
install:
- pip install -U pip setuptools
- pip install -U coverage coveralls
diff --git a/CHANGES.rst b/CHANGES.rst
index cd002c9..b7bd86b 100644
--- a/CHANGES.rst
+++ b/CHANGES.rst
@@ -5,7 +5,7 @@
4.3.2 (unreleased)
==================
-- Nothing changed yet.
+- Add support for Python 3.7.
4.3.1 (2017-12-19)
diff --git a/setup.py b/setup.py
index 8859443..980d991 100644
--- a/setup.py
+++ b/setup.py
@@ -83,6 +83,7 @@ setup(
'Programming Language :: Python :: 3.4',
'Programming Language :: Python :: 3.5',
'Programming Language :: Python :: 3.6',
+ 'Programming Language :: Python :: 3.7',
'Programming Language :: Python :: Implementation :: CPython',
'Programming Language :: Python :: Implementation :: PyPy',
'Natural Language :: English',
diff --git a/tox.ini b/tox.ini
index 524de93..d4a3cf9 100644
--- a/tox.ini
+++ b/tox.ini
@@ -1,6 +1,6 @@
[tox]
envlist =
- py27,py34,py35,py36,pypy,pypy3,coverage,docs
+ py27,py34,py35,py36,py37,pypy,pypy3,coverage,docs
[testenv]
commands =
@@ -23,6 +23,6 @@ deps =
[testenv:docs]
basepython =
- python2.7
+ python3.6
commands =
sphinx-build -b html -d docs/_build/doctrees docs docs/_build/html