summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSylvain Viollon <sviollon@minddistrict.com>2018-10-17 14:09:21 +0200
committerSylvain Viollon <sviollon@minddistrict.com>2018-10-17 14:09:21 +0200
commitfba2fd42d458a1229bfd0f58967cb2c13e00a84b (patch)
tree8c40f1ad3d6d9fa315b666446a52877d7d86ca51
parentd272fcc2d4dd2e69bf86d8750b7589de1960a50b (diff)
parentd16e9c5078907caca990073c84222e2520f7770c (diff)
downloadzope-i18n-fba2fd42d458a1229bfd0f58967cb2c13e00a84b.tar.gz
Merge remote-tracking branch 'zope/master' into CB-556-FR-translation
-rw-r--r--.travis.yml5
-rw-r--r--CHANGES.rst10
-rw-r--r--setup.py3
-rw-r--r--tox.ini4
4 files changed, 17 insertions, 5 deletions
diff --git a/.travis.yml b/.travis.yml
index e770bda..b2ff47d 100644
--- a/.travis.yml
+++ b/.travis.yml
@@ -7,6 +7,11 @@ python:
- 3.6
- pypy
- pypy3
+matrix:
+ include:
+ - python: "3.7"
+ dist: xenial
+ sudo: true
install:
- pip install -U pip setuptools
- pip install -U coverage coveralls
diff --git a/CHANGES.rst b/CHANGES.rst
index 538300b..18238e6 100644
--- a/CHANGES.rst
+++ b/CHANGES.rst
@@ -2,14 +2,20 @@
CHANGES
=========
-4.3.2 (unreleased)
-==================
+4.5 (unreleased)
+================
- Add support for pluralization. ``translate()`` now takes the
additional optional arguments ``msgid_plural``, ``default_plural``
and ``number`` in order to support it.
+4.4 (2018-10-05)
+================
+
+- Add support for Python 3.7.
+
+
4.3.1 (2017-12-19)
==================
diff --git a/setup.py b/setup.py
index 8859443..579eafe 100644
--- a/setup.py
+++ b/setup.py
@@ -59,7 +59,7 @@ TESTS_REQUIRE = COMPILE_REQUIRES + ZCML_REQUIRES + [
setup(
name='zope.i18n',
- version='4.3.2.dev0',
+ version='4.5.dev0',
author='Zope Foundation and Contributors',
author_email='zope-dev@zope.org',
description='Zope Internationalization Support',
@@ -83,6 +83,7 @@ setup(
'Programming Language :: Python :: 3.4',
'Programming Language :: Python :: 3.5',
'Programming Language :: Python :: 3.6',
+ 'Programming Language :: Python :: 3.7',
'Programming Language :: Python :: Implementation :: CPython',
'Programming Language :: Python :: Implementation :: PyPy',
'Natural Language :: English',
diff --git a/tox.ini b/tox.ini
index 524de93..d4a3cf9 100644
--- a/tox.ini
+++ b/tox.ini
@@ -1,6 +1,6 @@
[tox]
envlist =
- py27,py34,py35,py36,pypy,pypy3,coverage,docs
+ py27,py34,py35,py36,py37,pypy,pypy3,coverage,docs
[testenv]
commands =
@@ -23,6 +23,6 @@ deps =
[testenv:docs]
basepython =
- python2.7
+ python3.6
commands =
sphinx-build -b html -d docs/_build/doctrees docs docs/_build/html