summaryrefslogtreecommitdiff
path: root/setup.py
diff options
context:
space:
mode:
authorTres Seaver <tseaver@palladion.com>2012-04-06 19:37:12 +0000
committerTres Seaver <tseaver@palladion.com>2012-04-06 19:37:12 +0000
commit7928f025b3486283a9594b5782afdd9f1d5a5f48 (patch)
treedd3334c7972a49bf3ee48251da0170b877d32edf /setup.py
parenta783cd00da2705e2e238c27ea4340c7f9475be15 (diff)
downloadzope-exceptions-7928f025b3486283a9594b5782afdd9f1d5a5f48.tar.gz
Removed use of '2to3' and associated fixers when installing under Py3k.
The code is now in a "compatible subset" which supports Python 2.6, 2.7, and 3.2 We also now explicitly support PyPy 1.8 (the version compatible with the 2.7 language spec).
Diffstat (limited to 'setup.py')
-rw-r--r--setup.py8
1 files changed, 2 insertions, 6 deletions
diff --git a/setup.py b/setup.py
index a36e43d..c4a8d38 100644
--- a/setup.py
+++ b/setup.py
@@ -28,12 +28,6 @@ extra = {
}
}
-if sys.version_info >= (3, ):
- # Python 3 support:
- extra['use_2to3'] = True
- extra['setup_requires'] = ['zope.fixers']
- extra['use_2to3_fixers'] = ['zope.fixers']
-
def read(*rnames):
return open(os.path.join(os.path.dirname(__file__), *rnames)).read()
@@ -57,6 +51,8 @@ setup(name='zope.exceptions',
'Programming Language :: Python :: 2.7',
'Programming Language :: Python :: 3',
'Programming Language :: Python :: 3.2',
+ "Programming Language :: Python :: Implementation :: CPython",
+ "Programming Language :: Python :: Implementation :: PyPy",
'Natural Language :: English',
'Operating System :: OS Independent',
'Topic :: Internet :: WWW/HTTP',