summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--CHANGES.rst (renamed from CHANGES.txt)4
-rw-r--r--MANIFEST.in6
-rw-r--r--README.rst (renamed from README.txt)0
-rw-r--r--buildout.cfg2
-rw-r--r--setup.py11
-rw-r--r--src/zope/browser/tests.py6
-rw-r--r--tox.ini25
7 files changed, 43 insertions, 11 deletions
diff --git a/CHANGES.txt b/CHANGES.rst
index e75b60f..fdfaac7 100644
--- a/CHANGES.txt
+++ b/CHANGES.rst
@@ -4,6 +4,10 @@ Changelog
2.0.0 (unreleased)
------------------
+- Test coverage of 100% verified.
+
+- Added support for Python 3.3 and PyPy.
+
- Dropped support for Python 2.4 and 2.5.
1.3 (2010-04-30)
diff --git a/MANIFEST.in b/MANIFEST.in
new file mode 100644
index 0000000..26e6153
--- /dev/null
+++ b/MANIFEST.in
@@ -0,0 +1,6 @@
+include *.rst
+include *.txt
+
+recursive-include src *
+
+global-exclude *.pyc
diff --git a/README.txt b/README.rst
index 2cd8f82..2cd8f82 100644
--- a/README.txt
+++ b/README.rst
diff --git a/buildout.cfg b/buildout.cfg
index c4cfc8b..126b374 100644
--- a/buildout.cfg
+++ b/buildout.cfg
@@ -1,5 +1,5 @@
[buildout]
-develop = .
+develop = .
parts = test py
[test]
diff --git a/setup.py b/setup.py
index 31412c1..04795fa 100644
--- a/setup.py
+++ b/setup.py
@@ -11,9 +11,7 @@
# FOR A PARTICULAR PURPOSE.
#
##############################################################################
-"""Setup for zope.browser package
-"""
-
+"""Setup for zope.browser package"""
import os
from setuptools import setup, find_packages
@@ -27,11 +25,11 @@ setup(name='zope.browser',
author_email='zope-dev@zope.org',
description='Shared Zope Toolkit browser components',
long_description=(
- read('README.txt')
+ read('README.rst')
+ '\n\n.. contents::\n\n' +
read('src', 'zope', 'browser', 'README.txt')
+ '\n\n' +
- read('CHANGES.txt')
+ read('CHANGES.rst')
),
license='ZPL 2.1',
keywords = "zope browser component",
@@ -44,6 +42,8 @@ setup(name='zope.browser',
'Programming Language :: Python :: 2',
'Programming Language :: Python :: 2.6',
'Programming Language :: Python :: 2.7',
+ "Programming Language :: Python :: 3",
+ "Programming Language :: Python :: 3.3",
'Natural Language :: English',
'Operating System :: OS Independent',
'Topic :: Internet :: WWW/HTTP',
@@ -56,6 +56,7 @@ setup(name='zope.browser',
'setuptools',
'zope.interface',
],
+ test_suite='zope.browser.tests.test_suite',
include_package_data = True,
zip_safe = False,
)
diff --git a/src/zope/browser/tests.py b/src/zope/browser/tests.py
index 25437cc..6df50d2 100644
--- a/src/zope/browser/tests.py
+++ b/src/zope/browser/tests.py
@@ -11,11 +11,7 @@
# FOR A PARTICULAR PURPOSE.
#
##############################################################################
-"""
-Test Suite
-"""
-__docformat__ = "reStructuredText"
-
+"""Test Suite"""
import doctest
import unittest
diff --git a/tox.ini b/tox.ini
new file mode 100644
index 0000000..169878c
--- /dev/null
+++ b/tox.ini
@@ -0,0 +1,25 @@
+[tox]
+envlist =
+ py26,py27,py33,pypy
+
+[testenv]
+commands =
+ python setup.py test -q
+# without explicit deps, setup.py test will download a bunch of eggs into $PWD
+deps =
+ zope.interface
+
+[testenv:coverage]
+basepython =
+ python2.7
+commands =
+# The installed version messes up nose's test discovery / coverage reporting
+# So, we uninstall that from the environment, and then install the editable
+# version, before running nosetests.
+ pip uninstall -y zope.browser
+ pip install -e .
+ nosetests --with-xunit --with-xcoverage
+deps =
+ nose
+ coverage
+ nosexcover