summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--.gitignore12
-rw-r--r--CHANGES.rst2
-rw-r--r--setup.py7
-rw-r--r--tox.ini4
4 files changed, 20 insertions, 5 deletions
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 0000000..401eb52
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,12 @@
+*.pyc
+*.so
+*.dll
+__pycache__
+src/*.egg-info
+
+.installed.cfg
+.tox
+bin
+build
+develop-eggs
+parts
diff --git a/CHANGES.rst b/CHANGES.rst
index ebaaa70..526f1df 100644
--- a/CHANGES.rst
+++ b/CHANGES.rst
@@ -4,7 +4,7 @@ Changelog
2.0.2 (unreleased)
------------------
-- Nothing changed yet.
+- Add Trove classifiers indicating CPython, 3.2 and PyPy support.
2.0.1 (2013-02-11)
diff --git a/setup.py b/setup.py
index bf19b0f..dc4bf2b 100644
--- a/setup.py
+++ b/setup.py
@@ -42,8 +42,11 @@ setup(name='zope.browser',
'Programming Language :: Python :: 2',
'Programming Language :: Python :: 2.6',
'Programming Language :: Python :: 2.7',
- "Programming Language :: Python :: 3",
- "Programming Language :: Python :: 3.3",
+ 'Programming Language :: Python :: 3',
+ 'Programming Language :: Python :: 3.2',
+ 'Programming Language :: Python :: 3.3',
+ 'Programming Language :: Python :: Implementation :: CPython',
+ 'Programming Language :: Python :: Implementation :: PyPy',
'Natural Language :: English',
'Operating System :: OS Independent',
'Topic :: Internet :: WWW/HTTP',
diff --git a/tox.ini b/tox.ini
index 169878c..9e21456 100644
--- a/tox.ini
+++ b/tox.ini
@@ -1,11 +1,10 @@
[tox]
envlist =
- py26,py27,py33,pypy
+ py26,py27,py32,py33,pypy
[testenv]
commands =
python setup.py test -q
-# without explicit deps, setup.py test will download a bunch of eggs into $PWD
deps =
zope.interface
@@ -23,3 +22,4 @@ deps =
nose
coverage
nosexcover
+ zope.interface