summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--setup.py9
1 files changed, 9 insertions, 0 deletions
diff --git a/setup.py b/setup.py
index 367f371..a3a5d0f 100644
--- a/setup.py
+++ b/setup.py
@@ -1,7 +1,16 @@
#!/usr/bin/env python
+import os
+import sys
+
from setuptools import setup
+# HACK for setup.py build, this way it can find cffi and thus make the
+# extension
+for path in os.listdir("."):
+ if path.endswith(".egg"):
+ sys.path.append(path)
+
try:
from xattr import lib
except ImportError: