summaryrefslogtreecommitdiff
path: root/.travis/run.sh
diff options
context:
space:
mode:
Diffstat (limited to '.travis/run.sh')
-rwxr-xr-x.travis/run.sh12
1 files changed, 9 insertions, 3 deletions
diff --git a/.travis/run.sh b/.travis/run.sh
index 7f5b6bf..25cbf7d 100755
--- a/.travis/run.sh
+++ b/.travis/run.sh
@@ -7,9 +7,15 @@ if [[ -n "$PYENV_VERSION" ]]; then
eval "$(pyenv init -)"
fi
-python setup.py build_ext -i
-python -m compileall -f .
-python setup.py test
+if [[ -n "$PYPY_URL" ]]; then
+ cmd=./pypy
+else
+ cmd=python
+fi
+
+"$cmd" setup.py build_ext -i
+"$cmd" -m compileall -f .
+"$cmd" setup.py test
if [[ -n "$PYENV_VERSION" && $TRAVIS_OS_NAME == 'osx' ]]; then
python setup.py bdist_wheel