summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBob Ippolito <bob@redivi.com>2016-02-12 10:52:11 -0800
committerBob Ippolito <bob@redivi.com>2016-02-12 10:52:21 -0800
commit6cf6290eed28e45539fd31f5cb01cfd3257da477 (patch)
tree62cb20b15d6102fe4c6919c982ee5a76aa7a0959
parent02f54b688faf496033303f00433a37850100c4b5 (diff)
downloadxattr-6cf6290eed28e45539fd31f5cb01cfd3257da477.tar.gz
Added xattr/tests/*.py to MANIFEST.in #43v0.7.9
-rw-r--r--CHANGES.txt5
-rw-r--r--MANIFEST.in1
-rw-r--r--setup.py2
-rw-r--r--xattr/__init__.py2
4 files changed, 8 insertions, 2 deletions
diff --git a/CHANGES.txt b/CHANGES.txt
index bb46f94..a9686df 100644
--- a/CHANGES.txt
+++ b/CHANGES.txt
@@ -1,3 +1,8 @@
+Version 0.7.9 released 2016-02-12
+
+* Added xattr/tests/*.py to MANIFEST.in
+ https://github.com/xattr/xattr/issues/43
+
Version 0.7.8 released 2015-06-25
* Added MANIFEST.in to ensure that the .txt files are included
diff --git a/MANIFEST.in b/MANIFEST.in
index 77ea713..ce32cd3 100644
--- a/MANIFEST.in
+++ b/MANIFEST.in
@@ -1,3 +1,4 @@
include *.py
include *.txt
include MANIFEST.in
+include xattr/tests/*.py
diff --git a/setup.py b/setup.py
index 213a26d..00d9706 100644
--- a/setup.py
+++ b/setup.py
@@ -16,7 +16,7 @@ class cffi_build(build):
self.distribution.ext_modules = [ffi.verifier.get_extension()]
build.finalize_options(self)
-VERSION = '0.7.8'
+VERSION = '0.7.9'
DESCRIPTION = "Python wrapper for extended filesystem attributes"
LONG_DESCRIPTION = """
Extended attributes extend the basic attributes of files and directories
diff --git a/xattr/__init__.py b/xattr/__init__.py
index 905d1c7..c5e8433 100644
--- a/xattr/__init__.py
+++ b/xattr/__init__.py
@@ -7,7 +7,7 @@ The xattr type wraps a path or file descriptor with a dict-like interface
that exposes these extended attributes.
"""
-__version__ = '0.7.8'
+__version__ = '0.7.9'
from .lib import (XATTR_NOFOLLOW, XATTR_CREATE, XATTR_REPLACE,
XATTR_NOSECURITY, XATTR_MAXNAMELEN, XATTR_FINDERINFO_NAME,