summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBob Ippolito <bob@redivi.com>2015-06-19 11:47:12 +0200
committerBob Ippolito <bob@redivi.com>2015-06-19 11:47:12 +0200
commit79f701a34a19dc736a028373841a38c0c75d29d9 (patch)
tree3b43ed33f8c2200a1c9cc360a3500dc79aee80ff
parentab5d7cb61d03e739dedddf6c5c1235f6d05527f9 (diff)
downloadxattr-79f701a34a19dc736a028373841a38c0c75d29d9.tar.gz
v0.7.7v0.7.7
-rw-r--r--CHANGES.txt5
-rw-r--r--setup.py2
-rw-r--r--xattr/__init__.py2
3 files changed, 7 insertions, 2 deletions
diff --git a/CHANGES.txt b/CHANGES.txt
index 4bae368..22938ac 100644
--- a/CHANGES.txt
+++ b/CHANGES.txt
@@ -1,3 +1,8 @@
+Version 0.7.7 released 2015-06-19
+
+* Fixed FreeBSD build
+ https://github.com/xattr/xattr/pull/32
+
Version 0.7.6 released 2014-03-27
* Fixed Solaris & Solaris Studio support and Python 2.6 compatibility
diff --git a/setup.py b/setup.py
index 8a560d7..e082b33 100644
--- a/setup.py
+++ b/setup.py
@@ -16,7 +16,7 @@ class cffi_build(build):
self.distribution.ext_modules = [ffi.verifier.get_extension()]
build.finalize_options(self)
-VERSION = '0.7.6'
+VERSION = '0.7.7'
DESCRIPTION = "Python wrapper for extended filesystem attributes"
LONG_DESCRIPTION = """
Extended attributes extend the basic attributes of files and directories
diff --git a/xattr/__init__.py b/xattr/__init__.py
index de02f72..7fc4669 100644
--- a/xattr/__init__.py
+++ b/xattr/__init__.py
@@ -7,7 +7,7 @@ The xattr type wraps a path or file descriptor with a dict-like interface
that exposes these extended attributes.
"""
-__version__ = '0.7.6'
+__version__ = '0.7.7'
from .lib import (XATTR_NOFOLLOW, XATTR_CREATE, XATTR_REPLACE,
XATTR_NOSECURITY, XATTR_MAXNAMELEN, XATTR_FINDERINFO_NAME,