summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBob Ippolito <bob@redivi.com>2005-12-08 21:53:43 +0000
committerBob Ippolito <bob@redivi.com>2005-12-08 21:53:43 +0000
commit762cd9f289a955432d6d5c7f1040172acd27c687 (patch)
tree124777eebb1035fe79daa1e466723132253f265e
parentb04d47bec4f3c8b8573e7e04df44957079ab5e16 (diff)
downloadxattr-762cd9f289a955432d6d5c7f1040172acd27c687.tar.gz
refactor with setuptools
-rw-r--r--MANIFEST.in8
-rw-r--r--setup.cfg3
-rw-r--r--setup.py7
3 files changed, 8 insertions, 10 deletions
diff --git a/MANIFEST.in b/MANIFEST.in
deleted file mode 100644
index 09e1934..0000000
--- a/MANIFEST.in
+++ /dev/null
@@ -1,8 +0,0 @@
-include *.txt setup.py MANIFEST.in
-graft Lib
-graft Modules
-graft _build
-global-exclude .DS_store
-global-exclude *.pyc
-global-exclude *.pyo
-global-exclude .*.swp
diff --git a/setup.cfg b/setup.cfg
new file mode 100644
index 0000000..0c3455b
--- /dev/null
+++ b/setup.cfg
@@ -0,0 +1,3 @@
+[egg_info]
+tag_build = .dev
+tag_svn_revision = 1
diff --git a/setup.py b/setup.py
index ae78893..ac2c52d 100644
--- a/setup.py
+++ b/setup.py
@@ -1,7 +1,9 @@
#!/usr/bin/env python
-import distutils
-from distutils.core import setup, Extension
+import ez_setup
+ez_setup.use_setuptools()
+
+from setuptools import setup, Extension
VERSION = '0.2'
DESCRIPTION = "Python wrapper for extended filesystem attributes"
@@ -42,4 +44,5 @@ setup(
ext_modules=[
Extension("xattr._xattr", ["Modules/xattr/_xattr.c"]),
],
+ zip_safe=False,
)