summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBob Ippolito <bob@redivi.com>2018-01-21 15:31:40 -0800
committerBob Ippolito <bob@redivi.com>2018-01-21 15:31:40 -0800
commitcaf83bebd973a1631372ba8df90942b382d46bd1 (patch)
tree89da309c120299bf5c60351b4a92fa2b7eb84a39
parent3f96418121493efb32d5df9950448894548eb32d (diff)
downloadxattr-caf83bebd973a1631372ba8df90942b382d46bd1.tar.gz
try forcing an upgrade of the preinstalled pyenv
-rwxr-xr-x.travis/install.sh19
-rwxr-xr-x.travis/run.sh8
2 files changed, 7 insertions, 20 deletions
diff --git a/.travis/install.sh b/.travis/install.sh
index d51f0a3..e56cc8f 100755
--- a/.travis/install.sh
+++ b/.travis/install.sh
@@ -4,20 +4,11 @@ set -e
set -x
if [[ -n "$PYENV_VERSION" ]]; then
- if [ ! -e "$HOME/.pyenv-xattr/.git" ]; then
- if [ -e "$HOME/.pyenv-xattr" ]; then
- rm -rf ~/.pyenv-xattr
- fi
- git clone https://github.com/yyuu/pyenv.git ~/.pyenv-xattr
+ if [[ $TRAVIS_OS_NAME == 'osx' ]]; then
+ brew update && brew upgrade pyenv
fi
- PYENV_ROOT="$HOME/.pyenv-xattr"
- PYENV="$PYENV_ROOT/bin/pyenv"
- PATH="$PYENV_ROOT/bin:$PATH"
- (cd "$PYENV_ROOT" && git fetch origin && git reset --hard origin/master)
- hash -r
- eval "$("$PYENV" init -)"
- hash -r
- "$PYENV" install --list
- "$PYENV" install -s "$PYENV_VERSION"
+ eval "$(pyenv init -)"
+ pyenv install --list
+ pyenv install -s "$PYENV_VERSION"
pip install wheel
fi
diff --git a/.travis/run.sh b/.travis/run.sh
index b8aa468..7f5b6bf 100755
--- a/.travis/run.sh
+++ b/.travis/run.sh
@@ -4,11 +4,7 @@ set -e
set -x
if [[ -n "$PYENV_VERSION" ]]; then
- PYENV_ROOT="$HOME/.pyenv-xattr"
- PYENV="$PYENV_ROOT/bin/pyenv"
- PATH="$PYENV_ROOT/bin:$PATH"
- hash -r
- eval "$("$PYENV" init -)"
+ eval "$(pyenv init -)"
fi
python setup.py build_ext -i
@@ -16,7 +12,7 @@ python -m compileall -f .
python setup.py test
if [[ -n "$PYENV_VERSION" && $TRAVIS_OS_NAME == 'osx' ]]; then
- python setup.py bdist_wheel
+ python setup.py bdist_wheel
fi
if [[ $BUILD_SDIST == 'true' ]]; then
python setup.py sdist