summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBob Ippolito <bob@redivi.com>2017-04-02 12:19:13 -0700
committerBob Ippolito <bob@redivi.com>2017-04-02 12:19:13 -0700
commit3566e0d22d780426d8a31034b028ce2d967187fd (patch)
tree0d57e31e5cfdfaa33cf74f827edcae72db5cf6e8
parent85420e91be287ac9bb5ef2f1ae5e1b34131cc0b1 (diff)
downloadxattr-3566e0d22d780426d8a31034b028ce2d967187fd.tar.gz
v0.9.2v0.9.2
-rw-r--r--CHANGES.txt7
-rwxr-xr-xscripts/artifacts.py15
-rw-r--r--setup.py2
-rw-r--r--xattr/__init__.py2
4 files changed, 9 insertions, 17 deletions
diff --git a/CHANGES.txt b/CHANGES.txt
index ae5317f..e1d4141 100644
--- a/CHANGES.txt
+++ b/CHANGES.txt
@@ -1,3 +1,10 @@
+Version 0.9.2 released 2017-04-02
+
+* Fix BSD issue w/ lsattr and long attrs
+ https://github.com/xattr/xattr/pull/57
+* Remove unreachable code
+ https://github.com/xattr/xattr/pull/56
+
Version 0.9.1 released 2016-10-23
* Allow (Python 2) long for fd
diff --git a/scripts/artifacts.py b/scripts/artifacts.py
index c868c55..bdcab7b 100755
--- a/scripts/artifacts.py
+++ b/scripts/artifacts.py
@@ -23,20 +23,6 @@ def download_file(src_url, dest_path):
['curl', '-L', '-#', '-o', dest_path, src_url])
-def download_appveyor_artifacts():
- api_url = 'https://ci.appveyor.com/api'
- builds = get_json(
- '{}/projects/etrepum/xattr'.format(api_url))
-
- for job in builds['build']['jobs']:
- url = '{api_url}/buildjobs/{jobId}/artifacts'.format(
- api_url=api_url, **job)
- for artifact in get_json(url):
- download_file(
- '{url}/{fileName}'.format(url=url, **artifact),
- artifact['fileName'])
-
-
def download_github_artifacts():
release = get_json(
'https://api.github.com/repos/xattr/xattr/releases/latest')
@@ -71,7 +57,6 @@ def upload_artifacts(version):
subprocess.check_call(args)
def main():
- # download_appveyor_artifacts()
download_github_artifacts()
version = get_version()
sign_artifacts(version)
diff --git a/setup.py b/setup.py
index f334f41..4efafa0 100644
--- a/setup.py
+++ b/setup.py
@@ -5,7 +5,7 @@ import sys
from setuptools import setup
-VERSION = '0.9.1'
+VERSION = '0.9.2'
DESCRIPTION = "Python wrapper for extended filesystem attributes"
LONG_DESCRIPTION = """
Extended attributes extend the basic attributes of files and directories
diff --git a/xattr/__init__.py b/xattr/__init__.py
index 661b27a..6e605bd 100644
--- a/xattr/__init__.py
+++ b/xattr/__init__.py
@@ -7,7 +7,7 @@ The xattr type wraps a path or file descriptor with a dict-like interface
that exposes these extended attributes.
"""
-__version__ = '0.9.1'
+__version__ = '0.9.2'
from .compat import integer_types
from .lib import (XATTR_NOFOLLOW, XATTR_CREATE, XATTR_REPLACE,