summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBob Ippolito <bob@redivi.com>2014-03-03 10:13:48 -0800
committerBob Ippolito <bob@redivi.com>2014-03-03 10:13:48 -0800
commit30b17f4ba5aacaf2bf2b6d4382b316753c25783d (patch)
treeadd30c64728156a66e90666df43490c5c8282cb9
parentf461a6ded4933d4795e8ab1cfa98304c5763c085 (diff)
downloadxattr-30b17f4ba5aacaf2bf2b6d4382b316753c25783d.tar.gz
bump to 0.7.4, improve testsv0.7.4
-rw-r--r--.travis.yml2
-rw-r--r--CHANGES.txt5
-rw-r--r--setup.py2
-rw-r--r--xattr/__init__.py2
-rw-r--r--xattr/tests/test_xattr.py7
5 files changed, 14 insertions, 4 deletions
diff --git a/.travis.yml b/.travis.yml
index 89f8e9e..0683a3b 100644
--- a/.travis.yml
+++ b/.travis.yml
@@ -1,5 +1,5 @@
language: objective-c
script:
- python setup.py build_ext -i
- - python -m compileall -f .
+ - python -m compileall -f xattr
- python setup.py test
diff --git a/CHANGES.txt b/CHANGES.txt
index 8416182..8d80916 100644
--- a/CHANGES.txt
+++ b/CHANGES.txt
@@ -1,3 +1,8 @@
+Version 0.7.4 released 2014-03-03
+
+* Improved Python 3 compatibility
+ https://github.com/xattr/xattr/pull/22
+
Version 0.7.3 released 2014-01-06
* Added some unicode-specific tests
diff --git a/setup.py b/setup.py
index bdfeb1a..359535c 100644
--- a/setup.py
+++ b/setup.py
@@ -16,7 +16,7 @@ class cffi_build(build):
self.distribution.ext_modules = [ffi.verifier.get_extension()]
build.finalize_options(self)
-VERSION = '0.7.3'
+VERSION = '0.7.4'
DESCRIPTION = "Python wrapper for extended filesystem attributes"
LONG_DESCRIPTION = """
Extended attributes extend the basic attributes of files and directories
diff --git a/xattr/__init__.py b/xattr/__init__.py
index f10f781..fdbf05c 100644
--- a/xattr/__init__.py
+++ b/xattr/__init__.py
@@ -7,7 +7,7 @@ The xattr type wraps a path or file descriptor with a dict-like interface
that exposes these extended attributes.
"""
-__version__ = '0.7.3'
+__version__ = '0.7.4'
from .lib import (XATTR_NOFOLLOW, XATTR_CREATE, XATTR_REPLACE,
XATTR_NOSECURITY, XATTR_MAXNAMELEN, XATTR_FINDERINFO_NAME,
diff --git a/xattr/tests/test_xattr.py b/xattr/tests/test_xattr.py
index 807f66f..97194bd 100644
--- a/xattr/tests/test_xattr.py
+++ b/xattr/tests/test_xattr.py
@@ -9,6 +9,7 @@ class BaseTestXattr(object):
def test_attr(self):
x = xattr.xattr(self.tempfile)
self.assertEqual(x.keys(), [])
+ self.assertEqual(x.list(), [])
self.assertEqual(dict(x), {})
x['user.sopal'] = b'foo'
@@ -17,14 +18,18 @@ class BaseTestXattr(object):
del x
x = xattr.xattr(self.tempfile)
+ attrs = set(x.list())
self.assertTrue('user.sopal' in x)
+ self.assertTrue(u'user.sopal' in attrs)
self.assertEqual(x['user.sopal'], b'foo')
self.assertTrue('user.sop.foo' in x)
+ self.assertTrue(u'user.sop.foo' in attrs)
self.assertEqual(x['user.sop.foo'], b'bar')
self.assertTrue(u'user.\N{SNOWMAN}' in x)
+ self.assertTrue(u'user.\N{SNOWMAN}' in attrs)
self.assertEqual(x[u'user.\N{SNOWMAN}'],
b'not a snowman')
-
+
del x[u'user.\N{SNOWMAN}']
del x['user.sop.foo']
del x