summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBob Ippolito <bob@redivi.com>2012-02-01 11:30:56 -0800
committerBob Ippolito <bob@redivi.com>2012-02-01 11:30:56 -0800
commitffea9aef0bf8a4939b81813ee23f9f9b1713ad89 (patch)
tree4e3f39568394544700a388677307fe32ba8b53a0
parent5af7a2d7c493b0078b69297ffe79cec5ac76fcad (diff)
downloadxattr-ffea9aef0bf8a4939b81813ee23f9f9b1713ad89.tar.gz
bump version to 0.6.4, update READMEv0.6.4
-rw-r--r--CHANGES.txt7
-rw-r--r--README.txt6
-rw-r--r--setup.py2
-rw-r--r--xattr/__init__.py2
4 files changed, 12 insertions, 5 deletions
diff --git a/CHANGES.txt b/CHANGES.txt
index e355956..bfcb0ad 100644
--- a/CHANGES.txt
+++ b/CHANGES.txt
@@ -1,3 +1,10 @@
+Version 0.6.4 released 2012-02-01
+
+* Updated README.txt to match setup.py description
+ https://github.com/xattr/xattr/issues/5
+* Bug fixes for Solaris port
+ https://github.com/xattr/xattr/pull/2
+
Version 0.6.3 released 2012-01-23
* Fix tests for Linux, allow xattr on symlinks
diff --git a/README.txt b/README.txt
index 9343bb1..c1962ee 100644
--- a/README.txt
+++ b/README.txt
@@ -1,8 +1,8 @@
-xattr is a Python wrapper for Darwin's extended filesystem attributes
+xattr is a Python wrapper for extended filesystem attributes.
Extended attributes extend the basic attributes of files and directories
in the file system. They are stored as name:data pairs associated with
file system objects (files, directories, symlinks, etc).
-Extended attributes are currently only available on Darwin 8.0 and later.
-This corresponds to Mac OS X 10.4 (Tiger).
+Extended attributes are currently only available on Darwin 8.0+ (Mac OS X 10.4)
+and Linux 2.6+. Experimental support is included for Solaris and FreeBSD.
diff --git a/setup.py b/setup.py
index 01a6e5b..2dea527 100644
--- a/setup.py
+++ b/setup.py
@@ -5,7 +5,7 @@ ez_setup.use_setuptools()
from setuptools import setup, Extension
-VERSION = '0.6.3'
+VERSION = '0.6.4'
DESCRIPTION = "Python wrapper for extended filesystem attributes"
LONG_DESCRIPTION = """
Extended attributes extend the basic attributes of files and directories
diff --git a/xattr/__init__.py b/xattr/__init__.py
index cdeb382..d9431f9 100644
--- a/xattr/__init__.py
+++ b/xattr/__init__.py
@@ -7,7 +7,7 @@ The xattr type wraps a path or file descriptor with a dict-like interface
that exposes these extended attributes.
"""
-__version__ = '0.6.2'
+__version__ = '0.6.4'
from constants import XATTR_NOFOLLOW, XATTR_CREATE, XATTR_REPLACE, \
XATTR_NOSECURITY, XATTR_MAXNAMELEN, XATTR_FINDERINFO_NAME, \
XATTR_RESOURCEFORK_NAME