summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBob Ippolito <bob@redivi.com>2013-07-18 19:13:49 -0700
committerBob Ippolito <bob@redivi.com>2013-07-18 19:13:49 -0700
commitaeee86c18da491a3e6b2038ea4538c5b12f34b20 (patch)
treeea4dd0c18f6c8f7f33e35400e1307977dca707c8
parent14853111ea32a029c44f29f1f4b8edd43e9d1e5a (diff)
downloadxattr-aeee86c18da491a3e6b2038ea4538c5b12f34b20.tar.gz
add a .travis.yml and remove useless setup.cfg
-rw-r--r--.travis.yml10
-rw-r--r--setup.cfg3
2 files changed, 10 insertions, 3 deletions
diff --git a/.travis.yml b/.travis.yml
new file mode 100644
index 0000000..1cf9eb2
--- /dev/null
+++ b/.travis.yml
@@ -0,0 +1,10 @@
+language: python
+python:
+ - "2.5"
+ - "2.6"
+ - "2.7"
+ - "pypy"
+script:
+ - python setup.py build_ext -i
+ - python -m compileall -f .
+ - python setup.py test
diff --git a/setup.cfg b/setup.cfg
deleted file mode 100644
index 406686a..0000000
--- a/setup.cfg
+++ /dev/null
@@ -1,3 +0,0 @@
-[egg_info]
-#tag_build = dev
-#tag_svn_revision = true