summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlex Gaynor <alex.gaynor@gmail.com>2013-07-19 09:32:28 -0700
committerAlex Gaynor <alex.gaynor@gmail.com>2013-07-19 09:32:28 -0700
commit6c5421c586a69ef775a667b389075eab330a22a0 (patch)
tree66022e41c4efce0f62ffe6a352294a72985609ce
parent55dccf038770ccfdc1dd7e2396fc1b07a7b3ddb5 (diff)
downloadxattr-6c5421c586a69ef775a667b389075eab330a22a0.tar.gz
Improve the building (still doesn't work)
-rw-r--r--setup.py9
1 files changed, 9 insertions, 0 deletions
diff --git a/setup.py b/setup.py
index 367f371..a3a5d0f 100644
--- a/setup.py
+++ b/setup.py
@@ -1,7 +1,16 @@
#!/usr/bin/env python
+import os
+import sys
+
from setuptools import setup
+# HACK for setup.py build, this way it can find cffi and thus make the
+# extension
+for path in os.listdir("."):
+ if path.endswith(".egg"):
+ sys.path.append(path)
+
try:
from xattr import lib
except ImportError: