summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBob Ippolito <bob@redivi.com>2018-07-30 22:43:49 +0000
committerBob Ippolito <bob@redivi.com>2018-07-30 22:43:49 +0000
commitffeccb067de52fa6296d9063dec5897a2a79ecea (patch)
treed99c8c53d606b8d19b873149a7e0c849fb341d8e
parent2f1c0b2e8f8219a0540e566b194da0dc927010ad (diff)
downloadxattr-ffeccb067de52fa6296d9063dec5897a2a79ecea.tar.gz
v0.9.4v0.9.4
-rw-r--r--CHANGES.txt9
-rw-r--r--setup.py2
-rw-r--r--xattr/__init__.py2
3 files changed, 11 insertions, 2 deletions
diff --git a/CHANGES.txt b/CHANGES.txt
index cc99da7..866a73f 100644
--- a/CHANGES.txt
+++ b/CHANGES.txt
@@ -1,3 +1,12 @@
+Version 0.9.4 released 2018-07-30
+
+* Extract inline C code for syntax highlighting and easier maintenance
+ https://github.com/xattr/xattr/pull/75
+* Fix Travis build
+ https://github.com/xattr/xattr/pull/74
+* Always include sys/types.h (musl compatibility)
+ https://github.com/xattr/xattr/pull/73
+
Version 0.9.3 released 2018-01-28
* Do not attempt to use surrogateescape unless it is available
diff --git a/setup.py b/setup.py
index a643a47..d4e3384 100644
--- a/setup.py
+++ b/setup.py
@@ -5,7 +5,7 @@ import sys
from setuptools import setup
-VERSION = '0.9.3'
+VERSION = '0.9.4'
DESCRIPTION = "Python wrapper for extended filesystem attributes"
LONG_DESCRIPTION = """
Extended attributes extend the basic attributes of files and directories
diff --git a/xattr/__init__.py b/xattr/__init__.py
index 651d542..8a4573a 100644
--- a/xattr/__init__.py
+++ b/xattr/__init__.py
@@ -7,7 +7,7 @@ The xattr type wraps a path or file descriptor with a dict-like interface
that exposes these extended attributes.
"""
-__version__ = '0.9.3'
+__version__ = '0.9.4'
from .compat import integer_types
from .lib import (XATTR_NOFOLLOW, XATTR_CREATE, XATTR_REPLACE,