summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorchrBrd <chris@binaryspanner.com>2018-07-30 17:17:59 +0100
committerchrBrd <chris@binaryspanner.com>2018-07-30 17:17:59 +0100
commite222fa3668f02a02536da2b658441f635a426453 (patch)
tree339ad408c35981341101b55fb8c20ab1c986a375
parent72dba8177807165c383e33ad1de84cff8c17f1ad (diff)
downloadxattr-e222fa3668f02a02536da2b658441f635a426453.tar.gz
Modify `run.sh` to use PyPy if available.
-rwxr-xr-x.travis/run.sh12
1 files changed, 9 insertions, 3 deletions
diff --git a/.travis/run.sh b/.travis/run.sh
index 7f5b6bf..25cbf7d 100755
--- a/.travis/run.sh
+++ b/.travis/run.sh
@@ -7,9 +7,15 @@ if [[ -n "$PYENV_VERSION" ]]; then
eval "$(pyenv init -)"
fi
-python setup.py build_ext -i
-python -m compileall -f .
-python setup.py test
+if [[ -n "$PYPY_URL" ]]; then
+ cmd=./pypy
+else
+ cmd=python
+fi
+
+"$cmd" setup.py build_ext -i
+"$cmd" -m compileall -f .
+"$cmd" setup.py test
if [[ -n "$PYENV_VERSION" && $TRAVIS_OS_NAME == 'osx' ]]; then
python setup.py bdist_wheel