summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRyan Petrello <lists@ryanpetrello.com>2013-10-01 15:20:24 -0400
committerRyan Petrello <lists@ryanpetrello.com>2013-10-02 10:51:20 -0400
commit6bb3227165fe199de58a66b3699aee595b1076af (patch)
treea01baf6bb1c545c474d84c9678bda7e5212b5e8b
parentabcdd7affa4ecde6c6d3ee2fd50f801c02168841 (diff)
downloadwsme-6bb3227165fe199de58a66b3699aee595b1076af.tar.gz
Add a test environment against pecan's development (master) branch.
Change-Id: Id4c6a61be6a8ee9fa7d8ec1551c12ca448aa458f
-rw-r--r--tox-tmpl.ini34
-rw-r--r--tox.ini34
2 files changed, 66 insertions, 2 deletions
diff --git a/tox-tmpl.ini b/tox-tmpl.ini
index d655ee0..355f022 100644
--- a/tox-tmpl.ini
+++ b/tox-tmpl.ini
@@ -1,6 +1,6 @@
# content of: tox.ini , put in same dir as setup.py
[tox]
-envlist = py26,py26-nolxml,py27,py27-nolxml,py32,py32-nolxml,pypy,sphinxext,tg11,tg15,flask,cornice,coverage,py33,py33-nolxml,pep8
+envlist = py26,py26-nolxml,py27,py27-nolxml,py32,py32-nolxml,pypy,sphinxext,tg11,tg15,flask,cornice,coverage,py33,py33-nolxml,pecan-dev26,pecan-dev27,pecan-dev32,pecan-dev33,pep8
[common]
testtools=
@@ -173,6 +173,38 @@ commands=
{envbindir}/nosetests tests/test_cornice.py --with-xunit --xunit-file nosetests-{envname}.xml --verbose --with-coverage --cover-package wsmeext {posargs}
{envbindir}/coverage xml -o coverage-{envname}.xml wsme/*.py wsmeext/cornice.py
+[testenv:pecan-dev-base]
+deps=
+ {[common]testtools}
+ webtest
+ transaction
+ suds
+ https://github.com/stackforge/pecan/zipball/master
+
+[testenv:pecan-dev26]
+basepython=python2.6
+deps={[testenv:pecan-dev-base]deps}
+commands=
+ {envbindir}/nosetests tests/pecantest --with-xunit --xunit-file nosetests-{envname}.xml --verbose {posargs}
+
+[testenv:pecan-dev27]
+basepython=python2.7
+deps={[testenv:pecan-dev-base]deps}
+commands=
+ {envbindir}/nosetests tests/pecantest --with-xunit --xunit-file nosetests-{envname}.xml --verbose {posargs}
+
+[testenv:pecan-dev32]
+basepython=python3.2
+deps={[testenv:pecan-dev-base]deps}
+commands=
+ {envbindir}/nosetests tests/pecantest --with-xunit --xunit-file nosetests-{envname}.xml --verbose {posargs}
+
+[testenv:pecan-dev33]
+basepython=python3.3
+deps={[testenv:pecan-dev-base]deps}
+commands=
+ {envbindir}/nosetests tests/pecantest --with-xunit --xunit-file nosetests-{envname}.xml --verbose {posargs}
+
[testenv:coverage]
basepython=python
deps=
diff --git a/tox.ini b/tox.ini
index c761b21..0235f83 100644
--- a/tox.ini
+++ b/tox.ini
@@ -1,5 +1,5 @@
[tox]
-envlist = py26,py26-nolxml,py27,py27-nolxml,py32,py32-nolxml,pypy,sphinxext,tg11,tg15,flask,cornice,coverage,py33,py33-nolxml,pep8
+envlist = py26,py26-nolxml,py27,py27-nolxml,py32,py32-nolxml,pypy,sphinxext,tg11,tg15,flask,cornice,coverage,py33,py33-nolxml,pecan-dev26,pecan-dev27,pecan-dev32,pecan-dev33,pep8
[common]
testtools =
@@ -93,6 +93,38 @@ commands =
{envbindir}/nosetests tests/test_cornice.py --with-xunit --xunit-file nosetests-{envname}.xml --verbose --with-coverage --cover-package wsmeext {posargs}
{envbindir}/coverage xml -o coverage-{envname}.xml wsme/*.py wsmeext/cornice.py
+[testenv:pecan-dev-base]
+deps =
+ {[common]testtools}
+ webtest
+ transaction
+ suds
+ https://github.com/stackforge/pecan/zipball/master
+
+[testenv:pecan-dev26]
+basepython = python2.6
+deps = {[testenv:pecan-dev-base]deps}
+commands =
+ {envbindir}/nosetests tests/pecantest --with-xunit --xunit-file nosetests-{envname}.xml --verbose {posargs}
+
+[testenv:pecan-dev27]
+basepython = python2.7
+deps = {[testenv:pecan-dev-base]deps}
+commands =
+ {envbindir}/nosetests tests/pecantest --with-xunit --xunit-file nosetests-{envname}.xml --verbose {posargs}
+
+[testenv:pecan-dev32]
+basepython = python3.2
+deps = {[testenv:pecan-dev-base]deps}
+commands =
+ {envbindir}/nosetests tests/pecantest --with-xunit --xunit-file nosetests-{envname}.xml --verbose {posargs}
+
+[testenv:pecan-dev33]
+basepython = python3.3
+deps = {[testenv:pecan-dev-base]deps}
+commands =
+ {envbindir}/nosetests tests/pecantest --with-xunit --xunit-file nosetests-{envname}.xml --verbose {posargs}
+
[testenv:coverage]
basepython = python
deps =