summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorNate Coraor <nate@bx.psu.edu>2015-11-10 14:13:31 -0500
committerNate Coraor <nate@bx.psu.edu>2015-11-10 14:13:31 -0500
commit7e06215ea42efcce8e550a8ac8a17fc45c06d39f (patch)
treee502f211a5bacee0c39637bb4b9acfb94d72ee3f
parent67acc381050eb44d91c852e1c0ead2abff427293 (diff)
parentcaeaa0029c78c10101ec7107a8356e93817a2966 (diff)
downloadwheel-7e06215ea42efcce8e550a8ac8a17fc45c06d39f.tar.gz
Merge upstream changes
-rw-r--r--CHANGES.txt13
-rw-r--r--wheel/__init__.py2
-rw-r--r--wheel/metadata.py4
-rw-r--r--wheel/test/complex-dist/setup.py7
4 files changed, 22 insertions, 4 deletions
diff --git a/CHANGES.txt b/CHANGES.txt
index 333b415..afee416 100644
--- a/CHANGES.txt
+++ b/CHANGES.txt
@@ -1,3 +1,16 @@
+0.26.0
+======
+- Fix multiple entrypoint comparison failure on Python 3 (Issue #148)
+
+0.25.0
+======
+- Add Python 3.5 to tox configuration
+- Deterministic (sorted) metadata
+- Fix tagging for Python 3.5 compatibility
+- Support py2-none-'arch' and py3-none-'arch' tags
+- Treat data-only wheels as pure
+- Write to temporary file and rename when using wheel install --force
+
0.24.0
======
- The python tag used for pure-python packages is now .pyN (major version
diff --git a/wheel/__init__.py b/wheel/__init__.py
index b84d0e4..5a57ba7 100644
--- a/wheel/__init__.py
+++ b/wheel/__init__.py
@@ -1,2 +1,2 @@
# __variables__ with double-quoted values will be available in setup.py:
-__version__ = "0.25.0"
+__version__ = "0.26.0"
diff --git a/wheel/metadata.py b/wheel/metadata.py
index 02c0663..8756fde 100644
--- a/wheel/metadata.py
+++ b/wheel/metadata.py
@@ -191,8 +191,8 @@ def pkginfo_to_dict(path, distribution=None):
exports = OrderedDict()
for group, items in sorted(ep_map.items()):
exports[group] = OrderedDict()
- for item in sorted(items.values()):
- name, export = str(item).split(' = ', 1)
+ for item in sorted(map(str, items.values())):
+ name, export = item.split(' = ', 1)
exports[group][name] = export
if exports:
metadata['extensions']['python.exports'] = exports
diff --git a/wheel/test/complex-dist/setup.py b/wheel/test/complex-dist/setup.py
index 802dbaf..615d5dc 100644
--- a/wheel/test/complex-dist/setup.py
+++ b/wheel/test/complex-dist/setup.py
@@ -20,6 +20,11 @@ setup(name='complex-dist',
install_requires=["quux", "splort"],
extras_require={'simple':['simple.dist']},
tests_require=["foo", "bar>=10.0.0"],
- entry_points={'console_scripts':['complex-dist=complexdist:main']}
+ entry_points={
+ 'console_scripts': [
+ 'complex-dist=complexdist:main',
+ 'complex-dist2=complexdist:main',
+ ],
+ },
)