summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDaniel Holth <dholth@fastmail.fm>2014-04-10 21:48:54 -0400
committerDaniel Holth <dholth@fastmail.fm>2014-04-10 21:48:54 -0400
commita06cd5a1b84c9f3b7b6637b318643dca0a5caad6 (patch)
tree7be8604482a8f77836f0af09cf6fa58b64a54b01
parentde68e092aba8f44ad629a860adb5d35ba9a27379 (diff)
downloadwheel-a06cd5a1b84c9f3b7b6637b318643dca0a5caad6.tar.gz
docs update
-rw-r--r--docs/index.rst24
-rw-r--r--setup.py13
2 files changed, 25 insertions, 12 deletions
diff --git a/docs/index.rst b/docs/index.rst
index 7575c40..2a0192c 100644
--- a/docs/index.rst
+++ b/docs/index.rst
@@ -132,6 +132,30 @@ or::
[bdist_wheel]
python-tag = py32
+Defining conditional dependencies
+---------------------------------
+
+In wheel, the only way to have conditional dependencies (that might only be
+needed on certain platforms) is to use environment markers as defined by
+PEP 426.
+
+As of wheel 0.24.0, the recommended way to do this is in the setuptools
+`extras_require` parameter. A `:` separates the extra name from the marker.
+Wheel's own setup.py has an example::
+ extras_require={
+ ':python_version=="2.6"': ['argparse'],
+ 'signatures': ['keyring'],
+ 'signatures:sys_platform!="win32"': ['pyxdg'],
+ 'faster-signatures': ['ed25519ll'],
+ 'tool': []
+ },
+
+The extra named '' signifies a default requirement, as if it was passed to
+`install_requires`.
+
+Older versions of bdist_wheel supported passing requirements in a
+now-deprecated [metadata] section in setup.cfg.
+
Automatically sign wheel files
------------------------------
diff --git a/setup.py b/setup.py
index 84ef5a2..2128e1f 100644
--- a/setup.py
+++ b/setup.py
@@ -10,17 +10,6 @@ with codecs.open(os.path.join(os.path.dirname(__file__), 'wheel', '__init__.py')
encoding='utf8') as version_file:
metadata = dict(re.findall(r"""__([a-z]+)__ = "([^"]+)""", version_file.read()))
-#
-# All these requirements are overridden by setup.cfg when wheel is built
-# as a wheel:
-#
-signature_reqs = ['keyring']
-if sys.platform != 'win32':
- signature_reqs.append('pyxdg')
-install_requires = []
-if sys.version_info[:2] < (2, 7):
- install_requires.append('argparse')
-
setup(name='wheel',
version=metadata['version'],
description='A built-package format for Python.',
@@ -35,6 +24,7 @@ setup(name='wheel',
"Programming Language :: Python :: 3",
"Programming Language :: Python :: 3.2",
"Programming Language :: Python :: 3.3",
+ "Programming Language :: Python :: 3.4",
],
author='Daniel Holth',
author_email='dholth@fastmail.fm',
@@ -47,7 +37,6 @@ setup(name='wheel',
'wheel.tool',
'wheel.signatures'
],
- install_requires=install_requires,
extras_require={
':python_version=="2.6"': ['argparse'],
'signatures': ['keyring'],