summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDaniel Holth <dholth@fastmail.fm>2013-07-20 12:14:38 -0400
committerDaniel Holth <dholth@fastmail.fm>2013-07-20 12:14:38 -0400
commitfbb04541f6dcf97066f129d43f333a793fb7a294 (patch)
tree373ea7781403295f1ee1b2ed8adae33af7c70047
parenta623f4d499898e6f7ab2f1cc0b7bbe9165fd1b8b (diff)
downloadwheel-fbb04541f6dcf97066f129d43f333a793fb7a294.tar.gz
expose setup.py bdist_wheel --skip-scripts
-rw-r--r--wheel/bdist_wheel.py10
1 files changed, 8 insertions, 2 deletions
diff --git a/wheel/bdist_wheel.py b/wheel/bdist_wheel.py
index c571274..db6e338 100644
--- a/wheel/bdist_wheel.py
+++ b/wheel/bdist_wheel.py
@@ -71,6 +71,9 @@ class bdist_wheel(Command):
('group=', 'g',
"Group name used when creating a tar file"
" [default: current group]"),
+ ('skip-scripts', None,
+ "skip building the setuptools console_scripts",
+ "(default: false)"),
]
boolean_options = ['keep-temp', 'skip-build', 'relative']
@@ -89,6 +92,7 @@ class bdist_wheel(Command):
self.relative = False
self.owner = None
self.group = None
+ self.skip_scripts = False
def finalize_options(self):
if self.bdist_dir is None:
@@ -172,8 +176,10 @@ class bdist_wheel(Command):
install.skip_build = self.skip_build
install.warn_dir = False
- install_scripts = self.reinitialize_command('install_scripts')
- install_scripts.no_ep = True
+ if self.skip_scripts:
+ # A wheel without setuptools scripts is more cross-platform.
+ install_scripts = self.reinitialize_command('install_scripts')
+ install_scripts.no_ep = True
# Use a custom scheme for the archive, because we have to decide
# at installation time which scheme to use.