summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGael Pasgrimaud <gael@gawel.org>2012-11-13 01:28:08 +0100
committerGael Pasgrimaud <gael@gawel.org>2012-11-13 01:28:08 +0100
commit83fa145ba3df2a8adae51d3533d7f086c55336ce (patch)
tree89d045ea8b3937d47218c46fc567efe4577b1913
parente38c762dba98149c17dede3f6ef328554b20d79e (diff)
downloadwebtest-83fa145ba3df2a8adae51d3533d7f086c55336ce.tar.gz
add a readme
-rw-r--r--README.rst11
-rw-r--r--setup.py10
2 files changed, 12 insertions, 9 deletions
diff --git a/README.rst b/README.rst
new file mode 100644
index 0000000..a7480e1
--- /dev/null
+++ b/README.rst
@@ -0,0 +1,11 @@
+=======
+WebTest
+=======
+
+This wraps any WSGI application and makes it easy to send test
+requests to that application, without starting up an HTTP server.
+
+This provides convenient full-stack testing of applications written
+with any WSGI-compatible framework.
+
+Full docs can be found at https://webtest.readthedocs.org/en/latest/
diff --git a/setup.py b/setup.py
index 4e0de23..84a0dcb 100644
--- a/setup.py
+++ b/setup.py
@@ -7,15 +7,7 @@ version = '1.4.1'
setup(name='WebTest',
version=version,
description="Helper to test WSGI applications",
- long_description="""\
-This wraps any WSGI application and makes it easy to send test
-requests to that application, without starting up an HTTP server.
-
-This provides convenient full-stack testing of applications written
-with any WSGI-compatible framework.
-
-This is based on ``paste.fixture.TestApp``.
-""",
+ long_description=open('REAMDE.rst').read(),
classifiers=[
"Development Status :: 5 - Production/Stable",
"Framework :: Paste",