summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGael Pasgrimaud <gael@gawel.org>2014-04-15 21:58:55 +0200
committerGael Pasgrimaud <gael@gawel.org>2014-04-15 21:59:49 +0200
commitb725baf54036ae1cb332c909f6d0de0a344c717d (patch)
tree99f6252e2b2f5b284867a05164b25be0064ccefb
parent780f6d54944c31194e7a39ba0e5f2c69c4f24867 (diff)
downloadwebtest-b725baf54036ae1cb332c909f6d0de0a344c717d.tar.gz
rename .txt to .rst; also looks like the new nose.plugins.xunit break almost everything so we force 1.3.0
-rw-r--r--docs/Makefile6
-rw-r--r--docs/api.rst (renamed from docs/api.txt)0
l---------docs/changelog.rst (renamed from docs/changelog.txt)0
-rw-r--r--docs/conf.py2
-rw-r--r--docs/contributing.rst (renamed from docs/contributing.txt)4
-rw-r--r--docs/debugapp.rst (renamed from docs/debugapp.txt)0
-rw-r--r--docs/forms.rst (renamed from docs/forms.txt)0
-rw-r--r--docs/http.rst (renamed from docs/http.txt)0
-rw-r--r--docs/index.rst (renamed from docs/index.txt)10
-rw-r--r--docs/license.rst (renamed from docs/license.txt)0
-rw-r--r--docs/testapp.rst (renamed from docs/testapp.txt)0
-rw-r--r--docs/testresponse.rst (renamed from docs/testresponse.txt)2
-rw-r--r--docs/webtest.rst (renamed from docs/webtest.txt)8
-rw-r--r--setup.cfg6
-rw-r--r--setup.py2
-rw-r--r--tests/test_debugapp.py8
16 files changed, 22 insertions, 26 deletions
diff --git a/docs/Makefile b/docs/Makefile
index 4e324a7..0a46755 100644
--- a/docs/Makefile
+++ b/docs/Makefile
@@ -3,7 +3,7 @@
# You can set these variables from the command line.
SPHINXOPTS =
-SPHINXBUILD = ../bin/sphinx-build
+SPHINXBUILD = sphinx-build
PAPER =
BUILDDIR = _build
@@ -145,9 +145,9 @@ linkcheck:
$(SPHINXBUILD) -b linkcheck $(ALLSPHINXOPTS) $(BUILDDIR)/linkcheck
@echo
@echo "Link check complete; look for any errors in the above output " \
- "or in $(BUILDDIR)/linkcheck/output.txt."
+ "or in $(BUILDDIR)/linkcheck/output.rst."
doctest:
$(SPHINXBUILD) -b doctest $(ALLSPHINXOPTS) $(BUILDDIR)/doctest
@echo "Testing of doctests in the sources finished, look at the " \
- "results in $(BUILDDIR)/doctest/output.txt."
+ "results in $(BUILDDIR)/doctest/output.rst."
diff --git a/docs/api.txt b/docs/api.rst
index 48b196d..48b196d 100644
--- a/docs/api.txt
+++ b/docs/api.rst
diff --git a/docs/changelog.txt b/docs/changelog.rst
index e22698b..e22698b 120000
--- a/docs/changelog.txt
+++ b/docs/changelog.rst
diff --git a/docs/conf.py b/docs/conf.py
index bad1486..3cc794e 100644
--- a/docs/conf.py
+++ b/docs/conf.py
@@ -37,7 +37,7 @@ intersphinx_mapping = {
templates_path = ['_templates']
# The suffix of source filenames.
-source_suffix = '.txt'
+source_suffix = '.rst'
# The encoding of source files.
#source_encoding = 'utf-8-sig'
diff --git a/docs/contributing.txt b/docs/contributing.rst
index 5e7cc7d..32ae5ed 100644
--- a/docs/contributing.txt
+++ b/docs/contributing.rst
@@ -24,8 +24,8 @@ Execute tests
.. code-block:: bash
$ bin/nosetests
- Doctest: forms.txt ... ok
- Doctest: index.txt ... ok
+ Doctest: forms.rst ... ok
+ Doctest: index.rst ... ok
...
diff --git a/docs/debugapp.txt b/docs/debugapp.rst
index 2c565a3..2c565a3 100644
--- a/docs/debugapp.txt
+++ b/docs/debugapp.rst
diff --git a/docs/forms.txt b/docs/forms.rst
index 74fc6a3..74fc6a3 100644
--- a/docs/forms.txt
+++ b/docs/forms.rst
diff --git a/docs/http.txt b/docs/http.rst
index 63a2abb..63a2abb 100644
--- a/docs/http.txt
+++ b/docs/http.rst
diff --git a/docs/index.txt b/docs/index.rst
index 71f2753..0bc355a 100644
--- a/docs/index.txt
+++ b/docs/index.rst
@@ -116,9 +116,9 @@ Contents
.. toctree::
- webtest.txt
- api.txt
- contributing.txt
- changelog.txt
+ webtest.rst
+ api.rst
+ contributing.rst
+ changelog.rst
-.. include:: license.txt
+.. include:: license.rst
diff --git a/docs/license.txt b/docs/license.rst
index 60fc5df..60fc5df 100644
--- a/docs/license.txt
+++ b/docs/license.rst
diff --git a/docs/testapp.txt b/docs/testapp.rst
index 06bba54..06bba54 100644
--- a/docs/testapp.txt
+++ b/docs/testapp.rst
diff --git a/docs/testresponse.txt b/docs/testresponse.rst
index 80a5fe3..2b0ef75 100644
--- a/docs/testresponse.txt
+++ b/docs/testresponse.rst
@@ -82,7 +82,7 @@ The added methods:
.. toctree::
- forms.txt
+ forms.rst
Parsing the Body
diff --git a/docs/webtest.txt b/docs/webtest.rst
index 71ff170..11df5dd 100644
--- a/docs/webtest.txt
+++ b/docs/webtest.rst
@@ -5,10 +5,10 @@ Functional Testing of Web Applications
.. toctree::
- testapp.txt
- testresponse.txt
- http.txt
- debugapp.txt
+ testapp.rst
+ testresponse.rst
+ http.rst
+ debugapp.rst
Framework Hooks
diff --git a/setup.cfg b/setup.cfg
index 27e890e..2cadc63 100644
--- a/setup.cfg
+++ b/setup.cfg
@@ -6,11 +6,11 @@ dev = develop easy_install webtest[tests]
verbosity=2
detailed-errors = True
with-doctest = True
-doctest-extension = txt
+doctest-extension = rst
doctest-fixtures = _fixt
-# XXX: docs/index.txt requires lxml
+# XXX: docs/index.rst requires lxml
include = docs
-exclude = (changelog|contributing).txt
+exclude = (changelog|contributing).rst
cover-package=webtest
with-coverage=1
doctest-options = +ELLIPSIS,+NORMALIZE_WHITESPACE
diff --git a/setup.py b/setup.py
index df568c5..1a8b486 100644
--- a/setup.py
+++ b/setup.py
@@ -15,7 +15,7 @@ install_requires = [
]
tests_require = [
- 'nose', 'coverage', 'mock',
+ 'nose==1.3.0', 'coverage', 'mock',
'PasteDeploy', 'WSGIProxy2', 'pyquery'
]
diff --git a/tests/test_debugapp.py b/tests/test_debugapp.py
index 29960ca..5793a81 100644
--- a/tests/test_debugapp.py
+++ b/tests/test_debugapp.py
@@ -12,10 +12,7 @@ from webtest.app import AppError
from tests.compat import unittest
import webbrowser
-PY26 = sys.version_info[0:2] == (2, 6)
-
-@unittest.skipIf(PY26, 'issue with 2.6 and xunit')
def test_print_unicode():
print_stderr('°C')
@@ -49,12 +46,12 @@ class TestTesting(unittest.TestCase):
def test_post_unicode(self):
res = self.app.post('/', params=dict(a='é'),
- content_type='application/x-www-form-urlencoded;charset=utf8')
+ content_type='application/x-www-form-urlencoded;charset=utf8')
res.mustcontain('a=%C3%A9')
def test_post_unicode_body(self):
res = self.app.post('/', params='é',
- content_type='text/plain; charset=utf8')
+ content_type='text/plain; charset=utf8')
self.assertTrue(res.body.endswith(b'\xc3\xa9'))
res.mustcontain('é')
@@ -150,7 +147,6 @@ class TestTesting(unittest.TestCase):
self.app.get('/?status=404%20Not%20Found', status=404)
self.assertRaises(webtest.AppError, self.app.get, '/', status=404)
- @unittest.skipIf(PY26, 'issue with 2.6 and xunit')
def test_print_stderr(self):
res = self.app.get('/')
res.charset = 'utf-8'