summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSolly Ross <sross@redhat.com>2014-02-18 17:02:26 -0500
committerSolly Ross <sross@redhat.com>2014-02-18 17:03:09 -0500
commit739af6ecb46e762793508ab59fede1f6b647e44e (patch)
tree003a39ca6581f9956fdc8b87e1a90b978ed9b5ba
parent56b740ef5ca36cc7c50d654980b56d85a33c6cc9 (diff)
downloadwebsockify-739af6ecb46e762793508ab59fede1f6b647e44e.tar.gz
Update to v0.6.0v0.6.0
*** NOTE *** This version of websockify will break existing code which sub-classes `WebsocketProxy` -- see pull requests #110 and #111
-rw-r--r--CHANGES.txt9
-rw-r--r--other/js/package.json2
-rw-r--r--setup.py2
3 files changed, 11 insertions, 2 deletions
diff --git a/CHANGES.txt b/CHANGES.txt
index fa88628..76a5c55 100644
--- a/CHANGES.txt
+++ b/CHANGES.txt
@@ -1,6 +1,15 @@
Changes
=======
+0.6.0 - Feb 18, 2014
+--------------------
+
+* **NOTE** : 0.6.0 will break existing code that sub-classes WebsocketProxy
+* Refactor to use standard SocketServer RequestHandler design
+* Fix zombie process bug on certain systems when using multiprocessing
+* Add better unit tests
+* Log information via python `logging` module
+
0.5.1 - Jun 27, 2013
--------------------
diff --git a/other/js/package.json b/other/js/package.json
index ab6d478..c1422b8 100644
--- a/other/js/package.json
+++ b/other/js/package.json
@@ -3,7 +3,7 @@
"name": "websockify",
"description": "websockify is a WebSocket-to-TCP proxy/bridge",
"license": "LGPL-3",
- "version": "0.5.1",
+ "version": "0.6.0",
"repository": {
"type": "git",
"url": "git://github.com/kanaka/websockify.git"
diff --git a/setup.py b/setup.py
index d0e2c31..0ea9cce 100644
--- a/setup.py
+++ b/setup.py
@@ -1,6 +1,6 @@
from setuptools import setup, find_packages
-version = '0.5.1'
+version = '0.6.0'
name = 'websockify'
long_description = open("README.md").read() + "\n" + \
open("CHANGES.txt").read() + "\n"