summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHugo <hugovk@users.noreply.github.com>2018-08-14 14:12:22 +0300
committerHugo <hugovk@users.noreply.github.com>2018-08-14 14:12:22 +0300
commit4105d0fa2fe7a5e336c83b3c6ebde86d4f082f9f (patch)
tree9cd19e03db1b967546b6e24e65557af8aab8e8bc
parent0557f773119d5d97abd8b23c0b4b68966b107e2a (diff)
downloadwebsocket-client-4105d0fa2fe7a5e336c83b3c6ebde86d4f082f9f.tar.gz
Drop support for EOL Python <= 2.5
-rw-r--r--setup.py8
1 files changed, 5 insertions, 3 deletions
diff --git a/setup.py b/setup.py
index cbb8da6..a3599ca 100644
--- a/setup.py
+++ b/setup.py
@@ -12,12 +12,12 @@ tests_require = []
if sys.version_info[0] == 2 and sys.version_info[1] < 7:
tests_require.append('unittest2==0.8.0')
-insecure_pythons = '2.4, 2.5, 2.6, ' + ', '.join("2.7.{pv}".format(pv=pv) for pv in range(10))
+insecure_pythons = '2.6, ' + ', '.join("2.7.{pv}".format(pv=pv) for pv in range(10))
extras_require = {
':python_version in "{ips}"'.format(ips=insecure_pythons):
['backports.ssl_match_hostname'],
- ':python_version in "2.4, 2.5, 2.6"': ['argparse'],
+ ':python_version in "2.6"': ['argparse'],
}
try:
@@ -38,7 +38,7 @@ except Exception:
setup(
name=NAME,
version=VERSION,
- description="WebSocket client for python. hybi13 is supported.",
+ description="WebSocket client for Python. hybi13 is supported.",
long_description=open("README.rst").read(),
author="liris",
author_email="liris.pp@gmail.com",
@@ -50,6 +50,8 @@ setup(
"License :: OSI Approved :: GNU Library or Lesser General Public License (LGPL)",
"Programming Language :: Python",
"Programming Language :: Python :: 2",
+ "Programming Language :: Python :: 2.6",
+ "Programming Language :: Python :: 2.7",
"Programming Language :: Python :: 3",
"Programming Language :: Python :: 3.4",
"Programming Language :: Python :: 3.5",