summaryrefslogtreecommitdiff
path: root/pyproject.toml
diff options
context:
space:
mode:
Diffstat (limited to 'pyproject.toml')
-rw-r--r--pyproject.toml17
1 files changed, 16 insertions, 1 deletions
diff --git a/pyproject.toml b/pyproject.toml
index 7f50ece..b68b905 100644
--- a/pyproject.toml
+++ b/pyproject.toml
@@ -3,10 +3,25 @@ requires = ["setuptools >= 41"]
build-backend = "setuptools.build_meta"
[tool.black]
-py36 = false
+target-version = ['py35', 'py36', 'py37', 'py38']
exclude = '''
/(
\.git
| .tox
)/
'''
+
+ # This next section only exists for people that have their editors
+# automatically call isort, black already sorts entries on its own when run.
+[tool.isort]
+profile = "black"
+multi_line_output = 3
+src_paths = ["src", "tests"]
+skip_glob = ["docs/*"]
+include_trailing_comma = true
+force_grid_wrap = false
+combine_as_imports = true
+line_length = 88
+force_sort_within_sections = true
+default_section = "THIRDPARTY"
+known_first_party = "waitress"