summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDonald Stufft <donald@stufft.io>2018-05-16 14:27:28 -0400
committerDonald Stufft <donald@stufft.io>2018-05-16 14:27:28 -0400
commit73404cb6872b835cbc64f98c5c9c6c55ef798caf (patch)
tree645753c7aba257968692be25d465cbd874907443
parent2f5c75bd4762463e904aa1c06ccba29dd817e940 (diff)
downloadvirtualenv-73404cb6872b835cbc64f98c5c9c6c55ef798caf.tar.gz
Drop support for Python 2.6
-rw-r--r--.travis.yml2
-rw-r--r--appveyor.yml2
-rw-r--r--docs/changes.rst4
-rw-r--r--docs/index.rst12
-rw-r--r--setup.py6
-rw-r--r--tox.ini2
-rwxr-xr-xvirtualenv.py14
-rw-r--r--virtualenv_support/argparse-1.4.0-py2.py3-none-any.whlbin23000 -> 0 bytes
-rw-r--r--virtualenv_support/setuptools-36.8.0-py2.py3-none-any.whlbin482722 -> 0 bytes
-rw-r--r--virtualenv_support/wheel-0.29.0-py2.py3-none-any.whlbin66878 -> 0 bytes
10 files changed, 11 insertions, 31 deletions
diff --git a/.travis.yml b/.travis.yml
index 2f9aeab..9aea51b 100644
--- a/.travis.yml
+++ b/.travis.yml
@@ -3,8 +3,6 @@ language: python
matrix:
include:
# Based on https://docs.python.org/devguide/#status-of-python-branches
- - python: 2.6
- env: TOXENV=python2.6
- python: 2.7
env: TOXENV=python2.7
- python: 3.4
diff --git a/appveyor.yml b/appveyor.yml
index 4a01c45..d073e61 100644
--- a/appveyor.yml
+++ b/appveyor.yml
@@ -4,12 +4,10 @@ environment:
# For Python versions available on Appveyor, see
# http://www.appveyor.com/docs/installed-software#python
- - PYTHON: "C:\\Python26"
- PYTHON: "C:\\Python27"
- PYTHON: "C:\\Python34"
- PYTHON: "C:\\Python35"
- PYTHON: "C:\\Python36"
- - PYTHON: "C:\\Python26-x64"
- PYTHON: "C:\\Python27-x64"
- PYTHON: "C:\\Python34-x64"
- PYTHON: "C:\\Python35-x64"
diff --git a/docs/changes.rst b/docs/changes.rst
index 6cf7380..5e077ce 100644
--- a/docs/changes.rst
+++ b/docs/changes.rst
@@ -1,9 +1,11 @@
Release History
===============
-15.3.0 (unreleased)
+16.0.0 (unreleased)
-------------------
+* Drop support for Python 2.6.
+
15.2.0 (2018-03-21)
-------------------
diff --git a/docs/index.rst b/docs/index.rst
index e745a87..7c648ef 100644
--- a/docs/index.rst
+++ b/docs/index.rst
@@ -45,18 +45,6 @@ doesn't access the globally installed libraries either).
development
changes
-.. warning::
-
- Python bugfix releases 2.6.8, 2.7.3, 3.1.5 and 3.2.3 include a change that
- will cause "import random" to fail with "cannot import name urandom" on any
- virtualenv created on a Unix host with an earlier release of Python
- 2.6/2.7/3.1/3.2, if the underlying system Python is upgraded. This is due to
- the fact that a virtualenv uses the system Python's standard library but
- contains its own copy of the Python interpreter, so an upgrade to the system
- Python results in a mismatch between the version of the Python interpreter
- and the version of the standard library. It can be fixed by removing
- ``$ENV/bin/python`` and re-running virtualenv on the same target directory
- with the upgraded Python.
Other Documentation and Links
-----------------------------
diff --git a/setup.py b/setup.py
index add9bad..5e1f12b 100644
--- a/setup.py
+++ b/setup.py
@@ -3,8 +3,8 @@ import re
import shutil
import sys
-if sys.version_info[:2] < (2, 6):
- sys.exit('virtualenv requires Python 2.6 or higher.')
+if sys.version_info[:2] < (2, 7):
+ sys.exit('virtualenv requires Python 2.7 or higher.')
try:
from setuptools import setup
@@ -103,7 +103,6 @@ setup(
'Intended Audience :: Developers',
'License :: OSI Approved :: MIT License',
'Programming Language :: Python :: 2',
- 'Programming Language :: Python :: 2.6',
'Programming Language :: Python :: 2.7',
'Programming Language :: Python :: 3',
'Programming Language :: Python :: 3.4',
@@ -120,4 +119,5 @@ setup(
py_modules=['virtualenv'],
packages=['virtualenv_support'],
package_data={'virtualenv_support': ['*.whl']},
+ python_requires='>=2.7,!=3.0.*,!=3.1.*,!=3.2.*',
**setup_params)
diff --git a/tox.ini b/tox.ini
index 93b9447..1251a88 100644
--- a/tox.ini
+++ b/tox.ini
@@ -2,7 +2,7 @@
# env names must be a valid python binary name, unless they have a
# separate configuration
envlist =
- python{2.6,2.7,3.4,3.5,3.6}, pypy{,3}, crosspython{2,3}, docs
+ python{2.7,3.4,3.5,3.6}, pypy{,3}, crosspython{2,3}, docs
[testenv]
deps =
diff --git a/virtualenv.py b/virtualenv.py
index 90e9531..2648649 100755
--- a/virtualenv.py
+++ b/virtualenv.py
@@ -40,9 +40,9 @@ except ImportError:
__version__ = "15.3.0.dev0"
virtualenv_version = __version__ # legacy
-if sys.version_info < (2, 6):
+if sys.version_info < (2, 7):
print('ERROR: %s' % sys.exc_info()[1])
- print('ERROR: this script requires Python 2.6 or greater.')
+ print('ERROR: this script requires Python 2.7 or greater.')
sys.exit(101)
try:
@@ -931,19 +931,13 @@ def create_environment(home_dir, site_packages=False, clear=False,
to_install = []
if not no_setuptools:
- if sys.version_info[:2] == (2, 6):
- to_install.append('setuptools<37')
- else:
- to_install.append('setuptools')
+ to_install.append('setuptools')
if not no_pip:
to_install.append('pip')
if not no_wheel:
- if sys.version_info[:2] == (2, 6):
- to_install.append("wheel<0.30")
- else:
- to_install.append('wheel')
+ to_install.append('wheel')
if to_install:
install_wheel(
diff --git a/virtualenv_support/argparse-1.4.0-py2.py3-none-any.whl b/virtualenv_support/argparse-1.4.0-py2.py3-none-any.whl
deleted file mode 100644
index dfef51d..0000000
--- a/virtualenv_support/argparse-1.4.0-py2.py3-none-any.whl
+++ /dev/null
Binary files differ
diff --git a/virtualenv_support/setuptools-36.8.0-py2.py3-none-any.whl b/virtualenv_support/setuptools-36.8.0-py2.py3-none-any.whl
deleted file mode 100644
index c32c1f7..0000000
--- a/virtualenv_support/setuptools-36.8.0-py2.py3-none-any.whl
+++ /dev/null
Binary files differ
diff --git a/virtualenv_support/wheel-0.29.0-py2.py3-none-any.whl b/virtualenv_support/wheel-0.29.0-py2.py3-none-any.whl
deleted file mode 100644
index 506d5e5..0000000
--- a/virtualenv_support/wheel-0.29.0-py2.py3-none-any.whl
+++ /dev/null
Binary files differ