summaryrefslogtreecommitdiff
path: root/docs
diff options
context:
space:
mode:
Diffstat (limited to 'docs')
-rw-r--r--docs/Makefile153
-rw-r--r--docs/_templates/layout.html3
-rw-r--r--docs/manual/canvascache.txt (renamed from docs/canvascache.txt)0
-rw-r--r--docs/manual/displayattributes.txt (renamed from docs/displayattributes.txt)0
-rw-r--r--docs/manual/displaymodules.txt (renamed from docs/displaymodules.txt)0
-rw-r--r--docs/manual/eventloops.txt (renamed from docs/eventloops.txt)0
-rw-r--r--docs/manual/images/display_modules.png (renamed from docs/images/display_modules.png)bin16180 -> 16180 bytes
-rw-r--r--docs/manual/images/introduction.png (renamed from docs/images/introduction.png)bin25573 -> 25573 bytes
-rw-r--r--docs/manual/images/urwid_widgets_1.png (renamed from docs/images/urwid_widgets_1.png)bin48599 -> 48599 bytes
-rw-r--r--docs/manual/images/urwid_widgets_2.png (renamed from docs/images/urwid_widgets_2.png)bin60520 -> 60520 bytes
-rw-r--r--docs/manual/images/widget_layout.png (renamed from docs/images/widget_layout.png)bin19383 -> 19383 bytes
-rw-r--r--docs/manual/index.txt (renamed from docs/index.txt)0
-rw-r--r--docs/manual/intro.txt (renamed from docs/intro.txt)0
-rw-r--r--docs/manual/listboxcontents.txt (renamed from docs/listboxcontents.txt)0
-rw-r--r--docs/manual/mainloop.txt (renamed from docs/mainloop.txt)0
-rw-r--r--docs/manual/standardwidgets.txt (renamed from docs/standardwidgets.txt)0
-rw-r--r--docs/manual/textattributes.txt (renamed from docs/textattributes.txt)0
-rw-r--r--docs/manual/textencodings.txt (renamed from docs/textencodings.txt)0
-rw-r--r--docs/manual/textlayout.txt (renamed from docs/textlayout.txt)0
-rw-r--r--docs/manual/userinput.txt (renamed from docs/userinput.txt)0
-rw-r--r--docs/manual/widgetlayout.txt (renamed from docs/widgetlayout.txt)0
-rw-r--r--docs/manual/widgetmethods.txt (renamed from docs/widgetmethods.txt)0
22 files changed, 0 insertions, 156 deletions
diff --git a/docs/Makefile b/docs/Makefile
deleted file mode 100644
index 9ea7084..0000000
--- a/docs/Makefile
+++ /dev/null
@@ -1,153 +0,0 @@
-# Makefile for Sphinx documentation
-#
-
-# You can set these variables from the command line.
-SPHINXOPTS =
-SPHINXBUILD = sphinx-build
-PAPER =
-BUILDDIR = _build
-
-# Internal variables.
-PAPEROPT_a4 = -D latex_paper_size=a4
-PAPEROPT_letter = -D latex_paper_size=letter
-ALLSPHINXOPTS = -d $(BUILDDIR)/doctrees $(PAPEROPT_$(PAPER)) $(SPHINXOPTS) .
-# the i18n builder cannot share the environment and doctrees with the others
-I18NSPHINXOPTS = $(PAPEROPT_$(PAPER)) $(SPHINXOPTS) .
-
-.PHONY: help clean html dirhtml singlehtml pickle json htmlhelp qthelp devhelp epub latex latexpdf text man changes linkcheck doctest gettext
-
-help:
- @echo "Please use \`make <target>' where <target> is one of"
- @echo " html to make standalone HTML files"
- @echo " dirhtml to make HTML files named index.html in directories"
- @echo " singlehtml to make a single large HTML file"
- @echo " pickle to make pickle files"
- @echo " json to make JSON files"
- @echo " htmlhelp to make HTML files and a HTML help project"
- @echo " qthelp to make HTML files and a qthelp project"
- @echo " devhelp to make HTML files and a Devhelp project"
- @echo " epub to make an epub"
- @echo " latex to make LaTeX files, you can set PAPER=a4 or PAPER=letter"
- @echo " latexpdf to make LaTeX files and run them through pdflatex"
- @echo " text to make text files"
- @echo " man to make manual pages"
- @echo " texinfo to make Texinfo files"
- @echo " info to make Texinfo files and run them through makeinfo"
- @echo " gettext to make PO message catalogs"
- @echo " changes to make an overview of all changed/added/deprecated items"
- @echo " linkcheck to check all external links for integrity"
- @echo " doctest to run all doctests embedded in the documentation (if enabled)"
-
-clean:
- -rm -rf $(BUILDDIR)/*
-
-html:
- $(SPHINXBUILD) -b html $(ALLSPHINXOPTS) $(BUILDDIR)/html
- @echo
- @echo "Build finished. The HTML pages are in $(BUILDDIR)/html."
-
-dirhtml:
- $(SPHINXBUILD) -b dirhtml $(ALLSPHINXOPTS) $(BUILDDIR)/dirhtml
- @echo
- @echo "Build finished. The HTML pages are in $(BUILDDIR)/dirhtml."
-
-singlehtml:
- $(SPHINXBUILD) -b singlehtml $(ALLSPHINXOPTS) $(BUILDDIR)/singlehtml
- @echo
- @echo "Build finished. The HTML page is in $(BUILDDIR)/singlehtml."
-
-pickle:
- $(SPHINXBUILD) -b pickle $(ALLSPHINXOPTS) $(BUILDDIR)/pickle
- @echo
- @echo "Build finished; now you can process the pickle files."
-
-json:
- $(SPHINXBUILD) -b json $(ALLSPHINXOPTS) $(BUILDDIR)/json
- @echo
- @echo "Build finished; now you can process the JSON files."
-
-htmlhelp:
- $(SPHINXBUILD) -b htmlhelp $(ALLSPHINXOPTS) $(BUILDDIR)/htmlhelp
- @echo
- @echo "Build finished; now you can run HTML Help Workshop with the" \
- ".hhp project file in $(BUILDDIR)/htmlhelp."
-
-qthelp:
- $(SPHINXBUILD) -b qthelp $(ALLSPHINXOPTS) $(BUILDDIR)/qthelp
- @echo
- @echo "Build finished; now you can run "qcollectiongenerator" with the" \
- ".qhcp project file in $(BUILDDIR)/qthelp, like this:"
- @echo "# qcollectiongenerator $(BUILDDIR)/qthelp/Urwid.qhcp"
- @echo "To view the help file:"
- @echo "# assistant -collectionFile $(BUILDDIR)/qthelp/Urwid.qhc"
-
-devhelp:
- $(SPHINXBUILD) -b devhelp $(ALLSPHINXOPTS) $(BUILDDIR)/devhelp
- @echo
- @echo "Build finished."
- @echo "To view the help file:"
- @echo "# mkdir -p $$HOME/.local/share/devhelp/Urwid"
- @echo "# ln -s $(BUILDDIR)/devhelp $$HOME/.local/share/devhelp/Urwid"
- @echo "# devhelp"
-
-epub:
- $(SPHINXBUILD) -b epub $(ALLSPHINXOPTS) $(BUILDDIR)/epub
- @echo
- @echo "Build finished. The epub file is in $(BUILDDIR)/epub."
-
-latex:
- $(SPHINXBUILD) -b latex $(ALLSPHINXOPTS) $(BUILDDIR)/latex
- @echo
- @echo "Build finished; the LaTeX files are in $(BUILDDIR)/latex."
- @echo "Run \`make' in that directory to run these through (pdf)latex" \
- "(use \`make latexpdf' here to do that automatically)."
-
-latexpdf:
- $(SPHINXBUILD) -b latex $(ALLSPHINXOPTS) $(BUILDDIR)/latex
- @echo "Running LaTeX files through pdflatex..."
- $(MAKE) -C $(BUILDDIR)/latex all-pdf
- @echo "pdflatex finished; the PDF files are in $(BUILDDIR)/latex."
-
-text:
- $(SPHINXBUILD) -b text $(ALLSPHINXOPTS) $(BUILDDIR)/text
- @echo
- @echo "Build finished. The text files are in $(BUILDDIR)/text."
-
-man:
- $(SPHINXBUILD) -b man $(ALLSPHINXOPTS) $(BUILDDIR)/man
- @echo
- @echo "Build finished. The manual pages are in $(BUILDDIR)/man."
-
-texinfo:
- $(SPHINXBUILD) -b texinfo $(ALLSPHINXOPTS) $(BUILDDIR)/texinfo
- @echo
- @echo "Build finished. The Texinfo files are in $(BUILDDIR)/texinfo."
- @echo "Run \`make' in that directory to run these through makeinfo" \
- "(use \`make info' here to do that automatically)."
-
-info:
- $(SPHINXBUILD) -b texinfo $(ALLSPHINXOPTS) $(BUILDDIR)/texinfo
- @echo "Running Texinfo files through makeinfo..."
- make -C $(BUILDDIR)/texinfo info
- @echo "makeinfo finished; the Info files are in $(BUILDDIR)/texinfo."
-
-gettext:
- $(SPHINXBUILD) -b gettext $(I18NSPHINXOPTS) $(BUILDDIR)/locale
- @echo
- @echo "Build finished. The message catalogs are in $(BUILDDIR)/locale."
-
-changes:
- $(SPHINXBUILD) -b changes $(ALLSPHINXOPTS) $(BUILDDIR)/changes
- @echo
- @echo "The overview file is in $(BUILDDIR)/changes."
-
-linkcheck:
- $(SPHINXBUILD) -b linkcheck $(ALLSPHINXOPTS) $(BUILDDIR)/linkcheck
- @echo
- @echo "Link check complete; look for any errors in the above output " \
- "or in $(BUILDDIR)/linkcheck/output.txt."
-
-doctest:
- $(SPHINXBUILD) -b doctest $(ALLSPHINXOPTS) $(BUILDDIR)/doctest
- @echo "Testing of doctests in the sources finished, look at the " \
- "results in $(BUILDDIR)/doctest/output.txt."
diff --git a/docs/_templates/layout.html b/docs/_templates/layout.html
deleted file mode 100644
index 7ea8dfb..0000000
--- a/docs/_templates/layout.html
+++ /dev/null
@@ -1,3 +0,0 @@
-{% extends "!layout.html" %}
-{% set theme_nosidebar = True %}
-{#% block sidebar2 %}{% endblock %#}
diff --git a/docs/canvascache.txt b/docs/manual/canvascache.txt
index a7f2593..a7f2593 100644
--- a/docs/canvascache.txt
+++ b/docs/manual/canvascache.txt
diff --git a/docs/displayattributes.txt b/docs/manual/displayattributes.txt
index afe5362..afe5362 100644
--- a/docs/displayattributes.txt
+++ b/docs/manual/displayattributes.txt
diff --git a/docs/displaymodules.txt b/docs/manual/displaymodules.txt
index 3223b00..3223b00 100644
--- a/docs/displaymodules.txt
+++ b/docs/manual/displaymodules.txt
diff --git a/docs/eventloops.txt b/docs/manual/eventloops.txt
index f69155f..f69155f 100644
--- a/docs/eventloops.txt
+++ b/docs/manual/eventloops.txt
diff --git a/docs/images/display_modules.png b/docs/manual/images/display_modules.png
index 1246370..1246370 100644
--- a/docs/images/display_modules.png
+++ b/docs/manual/images/display_modules.png
Binary files differ
diff --git a/docs/images/introduction.png b/docs/manual/images/introduction.png
index 28ba10f..28ba10f 100644
--- a/docs/images/introduction.png
+++ b/docs/manual/images/introduction.png
Binary files differ
diff --git a/docs/images/urwid_widgets_1.png b/docs/manual/images/urwid_widgets_1.png
index 34606ea..34606ea 100644
--- a/docs/images/urwid_widgets_1.png
+++ b/docs/manual/images/urwid_widgets_1.png
Binary files differ
diff --git a/docs/images/urwid_widgets_2.png b/docs/manual/images/urwid_widgets_2.png
index 601fb74..601fb74 100644
--- a/docs/images/urwid_widgets_2.png
+++ b/docs/manual/images/urwid_widgets_2.png
Binary files differ
diff --git a/docs/images/widget_layout.png b/docs/manual/images/widget_layout.png
index ad1227e..ad1227e 100644
--- a/docs/images/widget_layout.png
+++ b/docs/manual/images/widget_layout.png
Binary files differ
diff --git a/docs/index.txt b/docs/manual/index.txt
index 4f52422..4f52422 100644
--- a/docs/index.txt
+++ b/docs/manual/index.txt
diff --git a/docs/intro.txt b/docs/manual/intro.txt
index 5398c7c..5398c7c 100644
--- a/docs/intro.txt
+++ b/docs/manual/intro.txt
diff --git a/docs/listboxcontents.txt b/docs/manual/listboxcontents.txt
index 5184f24..5184f24 100644
--- a/docs/listboxcontents.txt
+++ b/docs/manual/listboxcontents.txt
diff --git a/docs/mainloop.txt b/docs/manual/mainloop.txt
index 0834423..0834423 100644
--- a/docs/mainloop.txt
+++ b/docs/manual/mainloop.txt
diff --git a/docs/standardwidgets.txt b/docs/manual/standardwidgets.txt
index afee0f7..afee0f7 100644
--- a/docs/standardwidgets.txt
+++ b/docs/manual/standardwidgets.txt
diff --git a/docs/textattributes.txt b/docs/manual/textattributes.txt
index 97b2e47..97b2e47 100644
--- a/docs/textattributes.txt
+++ b/docs/manual/textattributes.txt
diff --git a/docs/textencodings.txt b/docs/manual/textencodings.txt
index 5437e47..5437e47 100644
--- a/docs/textencodings.txt
+++ b/docs/manual/textencodings.txt
diff --git a/docs/textlayout.txt b/docs/manual/textlayout.txt
index da506fb..da506fb 100644
--- a/docs/textlayout.txt
+++ b/docs/manual/textlayout.txt
diff --git a/docs/userinput.txt b/docs/manual/userinput.txt
index d647d26..d647d26 100644
--- a/docs/userinput.txt
+++ b/docs/manual/userinput.txt
diff --git a/docs/widgetlayout.txt b/docs/manual/widgetlayout.txt
index b2768c2..b2768c2 100644
--- a/docs/widgetlayout.txt
+++ b/docs/manual/widgetlayout.txt
diff --git a/docs/widgetmethods.txt b/docs/manual/widgetmethods.txt
index 1979837..1979837 100644
--- a/docs/widgetmethods.txt
+++ b/docs/manual/widgetmethods.txt