summaryrefslogtreecommitdiff
path: root/.travis.yml
diff options
context:
space:
mode:
Diffstat (limited to '.travis.yml')
-rw-r--r--.travis.yml6
1 files changed, 3 insertions, 3 deletions
diff --git a/.travis.yml b/.travis.yml
index 5ab83cc..0f7c765 100644
--- a/.travis.yml
+++ b/.travis.yml
@@ -1,11 +1,11 @@
language: python
python:
- - "2.6"
- "2.7_with_system_site_packages"
- "3.2_with_system_site_packages"
- "3.3"
- "3.4"
- "3.5"
+ - "3.6"
- "pypy"
before_install:
- "sudo apt-get update"
@@ -17,11 +17,11 @@ install:
- "[ $TRAVIS_PYTHON_VERSION == '3.2_with_system_site_packages' ] && pip install 'tornado<=4.3.0' || pip install twisted tornado"
script:
- "DEPS=\"$TRAVIS_PYTHON_VERSION `python bin/deps.py`\"; echo $DEPS"
- - "[ \"$DEPS\" == '2.6 tornado twisted' -o
- \"$DEPS\" == '2.7_with_system_site_packages pygobject tornado twisted' -o
+ - "[ \"$DEPS\" == '2.7_with_system_site_packages pygobject tornado twisted' -o
\"$DEPS\" == '3.2_with_system_site_packages pygobject tornado' -o
\"$DEPS\" == '3.3 tornado twisted' -o
\"$DEPS\" == '3.4 tornado twisted' -o
\"$DEPS\" == '3.5 tornado twisted' -o
+ \"$DEPS\" == '3.6 tornado twisted' -o
\"$DEPS\" == 'pypy tornado twisted' ]"
- "python setup.py test"