summaryrefslogtreecommitdiff
path: root/setup.py
diff options
context:
space:
mode:
authorIan Ward <ian@excess.org>2011-02-16 12:21:41 -0500
committerIan Ward <ian@excess.org>2011-02-16 12:21:41 -0500
commitb0e874af1d152b123b8773f82e0694a7928d0e37 (patch)
tree18f3df452ac69a3a611a8328dad2a16edf85e9d2 /setup.py
parent5e173338cc90bbc1a6081aca29f4168f4973bd9c (diff)
downloadurwid-b0e874af1d152b123b8773f82e0694a7928d0e37.tar.gz
merge str_util_python3.c into str_util.c
--HG-- branch : python3
Diffstat (limited to 'setup.py')
-rw-r--r--setup.py8
1 files changed, 5 insertions, 3 deletions
diff --git a/setup.py b/setup.py
index 8cf1fe0..bdc46f1 100644
--- a/setup.py
+++ b/setup.py
@@ -28,7 +28,10 @@ except ImportError:
import os
-PYTHON3 = not str is bytes
+try:
+ PYTHON3 = not str is bytes
+except NameError:
+ PYTHON3 = False
exec(open(os.path.join("urwid","version.py")).read())
release = __version__
@@ -38,8 +41,7 @@ setup_d = {
'version':release,
'author':"Ian Ward",
'author_email':"ian@excess.org",
- 'ext_modules':[Extension('urwid.str_util',
- sources=['source/str_util%s.c' % ("_python3" * PYTHON3)])],
+ 'ext_modules':[Extension('urwid.str_util', sources=['source/str_util.c'])],
'url':"http://excess.org/urwid/",
'download_url':"http://excess.org/urwid/urwid-%s.tar.gz"%release,
'license':"LGPL",