summaryrefslogtreecommitdiff
path: root/setup.py
diff options
context:
space:
mode:
authorian <none@none>2004-10-17 21:14:29 +0000
committerian <none@none>2004-10-17 21:14:29 +0000
commit0633ffbbce5f2dcbd2f6df844111b806b7bcc521 (patch)
treebc5d31d99146758f88f1a6d2557ac28214d37739 /setup.py
parentf3a0bfaa828d28444c341bec68e23f7266cc9787 (diff)
downloadurwid-0633ffbbce5f2dcbd2f6df844111b806b7bcc521.tar.gz
release-0.8.0release-0.8.0
--HG-- extra : convert_revision : 1d04412f7d32aaa07db13dc30590d7cb0d6ea0f6
Diffstat (limited to 'setup.py')
-rw-r--r--setup.py34
1 files changed, 34 insertions, 0 deletions
diff --git a/setup.py b/setup.py
new file mode 100644
index 0000000..9636425
--- /dev/null
+++ b/setup.py
@@ -0,0 +1,34 @@
+#!/usr/bin/env python
+#
+# Urwid setup.py exports the useful bits
+# Copyright (C) 2004 Ian Ward
+#
+# This program is free software; you can redistribute it and/or modify
+# it under the terms of the GNU General Public License as published by
+# the Free Software Foundation; either version 2 of the License, or
+# (at your option) any later version.
+#
+# This program is distributed in the hope that it will be useful,
+# but WITHOUT ANY WARRANTY; without even the implied warranty of
+# MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
+# GNU General Public License for more details.
+#
+# You should have received a copy of the GNU General Public License
+# along with this program; if not, write to the Free Software
+# Foundation, Inc., 59 Temple Place, Suite 330, Boston, MA 02111-1307 USA
+#
+# Urwid web site: http://excess.org/urwid/
+
+from distutils.core import setup
+
+import os
+
+setup( name="urwid",
+ version=os.popen("make -s release").read().strip(),
+ description="urwid -- curses-based UI/widget library",
+ author="Ian Ward",
+ author_email="ian@excess.org",
+ url="http://excess.org/urwid/",
+ packages=['urwid'],
+ )
+