summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorIan Ward <ian@excess.org>2014-02-09 09:32:52 -0500
committerIan Ward <ian@excess.org>2014-02-09 09:32:52 -0500
commit6540a69473ea3dd823e9027369b8e1980301219a (patch)
tree2b83288ff504e52f4335c2100e7d4d759c402f90
parent87f9b9e71e89d4097187f9680230374da16a64a4 (diff)
downloadurwid-6540a69473ea3dd823e9027369b8e1980301219a.tar.gz
drop 2.4, 2.5 support, add PyPy
-rw-r--r--docs/tools/templates/indexcontent.html2
-rw-r--r--setup.py6
2 files changed, 4 insertions, 4 deletions
diff --git a/docs/tools/templates/indexcontent.html b/docs/tools/templates/indexcontent.html
index 037ee7c..784cd83 100644
--- a/docs/tools/templates/indexcontent.html
+++ b/docs/tools/templates/indexcontent.html
@@ -37,7 +37,7 @@
<div class="section" id="requirements">
<h3>Requirements</h3>
<ul>
-<li>Python 2.4, 2.5, 2.6, 2.7, 3.2 or 3.3</li>
+<li>Python 2.6, 2.7, 3.2+ or PyPy</li>
<li>Linux, OSX, Cygwin or other unix-like OS</li>
<li>python-gi for GlibEventLoop (optional)</li>
<li>Twisted for TwistedEventLoop (optional)</li>
diff --git a/setup.py b/setup.py
index e2ebd01..6a4d61b 100644
--- a/setup.py
+++ b/setup.py
@@ -1,7 +1,7 @@
#!/usr/bin/python
#
# Urwid setup.py exports the useful bits
-# Copyright (C) 2004-2012 Ian Ward
+# Copyright (C) 2004-2014 Ian Ward
#
# This library is free software; you can redistribute it and/or
# modify it under the terms of the GNU Lesser General Public
@@ -63,13 +63,13 @@ setup_d = {
"Topic :: Software Development :: Libraries :: Python Modules",
"Topic :: Software Development :: Widget Sets",
"Programming Language :: Python :: 2",
- "Programming Language :: Python :: 2.4",
- "Programming Language :: Python :: 2.5",
"Programming Language :: Python :: 2.6",
"Programming Language :: Python :: 2.7",
"Programming Language :: Python :: 3",
"Programming Language :: Python :: 3.2",
"Programming Language :: Python :: 3.3",
+ "Programming Language :: Python :: 3.4",
+ "Programming Language :: Python :: Implementation :: PyPy",
],
}