summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorOndřej Súkup <mimi1vx@users.noreply.github.com>2017-06-26 19:22:45 +0200
committerGitHub <noreply@github.com>2017-06-26 19:22:45 +0200
commit4e2af0433a8b633d2c5f6f714396ba42e3cc1e9d (patch)
tree54f0a3ae8f36dfc64ba3a5d44b59e476054f76f4
parent949f4ec91a0a4700c9784dc6e382e02e23a807f7 (diff)
downloadurwid-4e2af0433a8b633d2c5f6f714396ba42e3cc1e9d.tar.gz
Update travis to check python 3.6
python-2.6 is out of support and some distributions moving to python-3.6
-rw-r--r--.travis.yml6
1 files changed, 3 insertions, 3 deletions
diff --git a/.travis.yml b/.travis.yml
index 5ab83cc..0f7c765 100644
--- a/.travis.yml
+++ b/.travis.yml
@@ -1,11 +1,11 @@
language: python
python:
- - "2.6"
- "2.7_with_system_site_packages"
- "3.2_with_system_site_packages"
- "3.3"
- "3.4"
- "3.5"
+ - "3.6"
- "pypy"
before_install:
- "sudo apt-get update"
@@ -17,11 +17,11 @@ install:
- "[ $TRAVIS_PYTHON_VERSION == '3.2_with_system_site_packages' ] && pip install 'tornado<=4.3.0' || pip install twisted tornado"
script:
- "DEPS=\"$TRAVIS_PYTHON_VERSION `python bin/deps.py`\"; echo $DEPS"
- - "[ \"$DEPS\" == '2.6 tornado twisted' -o
- \"$DEPS\" == '2.7_with_system_site_packages pygobject tornado twisted' -o
+ - "[ \"$DEPS\" == '2.7_with_system_site_packages pygobject tornado twisted' -o
\"$DEPS\" == '3.2_with_system_site_packages pygobject tornado' -o
\"$DEPS\" == '3.3 tornado twisted' -o
\"$DEPS\" == '3.4 tornado twisted' -o
\"$DEPS\" == '3.5 tornado twisted' -o
+ \"$DEPS\" == '3.6 tornado twisted' -o
\"$DEPS\" == 'pypy tornado twisted' ]"
- "python setup.py test"