summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSeth M. Larson <SethMichaelLarson@users.noreply.github.com>2018-05-27 08:57:00 -0500
committerGitHub <noreply@github.com>2018-05-27 08:57:00 -0500
commit27e3c834eb3c9e1bde84f83dc05f4f44014de94e (patch)
treea837a2b55b25d851e82519d06d55d13efb500385
parent30e9855307aaa9f9f09651f2bbddeb7350eed666 (diff)
downloadurllib3-27e3c834eb3c9e1bde84f83dc05f4f44014de94e.tar.gz
Pin pyOpenSSL major version to 17.* for Python 2.6
See: https://github.com/pyca/pyopenssl/blob/74de8a137d435d45c100b74cc971be556166a559/CHANGELOG.rst#1800-2018-05-16
-rwxr-xr-xsetup.py8
1 files changed, 7 insertions, 1 deletions
diff --git a/setup.py b/setup.py
index 3aa9ccf0..f4cafb7b 100755
--- a/setup.py
+++ b/setup.py
@@ -19,6 +19,12 @@ with codecs.open('CHANGES.rst', encoding='utf-8') as fp:
changes = fp.read()
version = VERSION
+# pyOpenSSL version 18.0.0 dropped support for Python 2.6
+if sys.version_info < (2, 7):
+ PYOPENSSL_VERSION += 'pyOpenSSL >= 0.14, < 18.0.0'
+else:
+ PYOPENSSL_VERSION = 'pyOpenSSL >= 0.14'
+
setup(name='urllib3',
version=version,
description="HTTP library with thread-safe connection pooling, file post, and more.",
@@ -63,7 +69,7 @@ setup(name='urllib3',
test_suite='test',
extras_require={
'secure': [
- 'pyOpenSSL>=0.14',
+ PYOPENSSL_VERSION,
'cryptography>=1.3.4',
'idna>=2.0.0',
'certifi',