summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorQuentin Pradet <quentin.pradet@gmail.com>2020-09-09 16:53:28 +0400
committerSeth Michael Larson <sethmichaellarson@gmail.com>2020-09-13 22:25:31 -0500
commitdfb003a034bff89d3527c0cc7a37e2142e919a83 (patch)
tree64fbeff8f9ed474c8b4ffb77d36e035ba31690a8
parent3c3fb0299f5e56613003bc293a9a9082e264c982 (diff)
downloadurllib3-dfb003a034bff89d3527c0cc7a37e2142e919a83.tar.gz
[1.25] Rename _travis/ to ci/
Before using upload_coverage.sh in GitHub Actions
-rw-r--r--.github/CODEOWNERS2
-rw-r--r--.travis.yml8
-rwxr-xr-xci/deploy.sh (renamed from _travis/deploy.sh)0
-rwxr-xr-xci/downstream/botocore.sh (renamed from _travis/downstream/botocore.sh)0
-rw-r--r--ci/downstream/requests-requirements.txt (renamed from _travis/downstream/requests-requirements.txt)0
-rwxr-xr-xci/downstream/requests.sh (renamed from _travis/downstream/requests.sh)2
-rwxr-xr-xci/install.sh (renamed from _travis/install.sh)0
-rwxr-xr-xci/run.sh (renamed from _travis/run.sh)2
-rwxr-xr-xci/upload_coverage.sh (renamed from _travis/upload_coverage.sh)0
9 files changed, 7 insertions, 7 deletions
diff --git a/.github/CODEOWNERS b/.github/CODEOWNERS
index 9a14747c..9dadfa91 100644
--- a/.github/CODEOWNERS
+++ b/.github/CODEOWNERS
@@ -4,5 +4,5 @@
.github/CODEOWNERS @sethmlarson @shazow
src/urllib3/_version.py @sethmlarson @shazow
setup.py @sethmlarson @shazow
-_travis/ @sethmlarson @shazow
+ci/ @sethmlarson @shazow
.travis.yml @sethmlarson @shazow
diff --git a/.travis.yml b/.travis.yml
index 0d39e742..dfa65574 100644
--- a/.travis.yml
+++ b/.travis.yml
@@ -8,11 +8,11 @@ before_install:
- python -c "import ssl; print(ssl.OPENSSL_VERSION)"
install:
- - ./_travis/install.sh
+ - ./ci/install.sh
script:
- - ./_travis/run.sh
- - ./_travis/upload_coverage.sh
+ - ./ci/run.sh
+ - ./ci/upload_coverage.sh
cache:
directories:
@@ -82,7 +82,7 @@ jobs:
- python: 3.7
stage: deploy
script:
- - ./_travis/deploy.sh
+ - ./ci/deploy.sh
stages:
- name: test
diff --git a/_travis/deploy.sh b/ci/deploy.sh
index 503f0723..503f0723 100755
--- a/_travis/deploy.sh
+++ b/ci/deploy.sh
diff --git a/_travis/downstream/botocore.sh b/ci/downstream/botocore.sh
index 49ec3fe8..49ec3fe8 100755
--- a/_travis/downstream/botocore.sh
+++ b/ci/downstream/botocore.sh
diff --git a/_travis/downstream/requests-requirements.txt b/ci/downstream/requests-requirements.txt
index 82e33e9a..82e33e9a 100644
--- a/_travis/downstream/requests-requirements.txt
+++ b/ci/downstream/requests-requirements.txt
diff --git a/_travis/downstream/requests.sh b/ci/downstream/requests.sh
index 718193cb..f7afdb8b 100755
--- a/_travis/downstream/requests.sh
+++ b/ci/downstream/requests.sh
@@ -7,7 +7,7 @@ case "${1}" in
git clone --depth 1 https://github.com/psf/requests
cd requests
git rev-parse HEAD
- python -m pip install -r ${TRAVIS_BUILD_DIR}/_travis/downstream/requests-requirements.txt
+ python -m pip install -r ${TRAVIS_BUILD_DIR}/ci/downstream/requests-requirements.txt
python -m pip install .
;;
run)
diff --git a/_travis/install.sh b/ci/install.sh
index adda3d13..adda3d13 100755
--- a/_travis/install.sh
+++ b/ci/install.sh
diff --git a/_travis/run.sh b/ci/run.sh
index 36feb1b1..f72aacd6 100755
--- a/_travis/run.sh
+++ b/ci/run.sh
@@ -5,7 +5,7 @@ set -exo pipefail
if [ -n "${NOX_SESSION}" ]; then
nox -s "${NOX_SESSION}"
else
- downstream_script="${TRAVIS_BUILD_DIR}/_travis/downstream/${DOWNSTREAM}.sh"
+ downstream_script="${TRAVIS_BUILD_DIR}/ci/downstream/${DOWNSTREAM}.sh"
if [ ! -x "$downstream_script" ]; then
exit 1
fi
diff --git a/_travis/upload_coverage.sh b/ci/upload_coverage.sh
index e71fd122..e71fd122 100755
--- a/_travis/upload_coverage.sh
+++ b/ci/upload_coverage.sh