summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlex Chan <alex@alexwlchan.net>2016-11-01 22:29:39 +0000
committerAlex Chan <alex@alexwlchan.net>2016-11-02 08:26:58 +0000
commit080d42000fca8b06391615f83ee665e9c3f38513 (patch)
tree4326b0129710114d2d4128e99f8b14a732a1d39a
parent2198b73f0d67080e66fc41bf5c3024650087c644 (diff)
downloadurllib3-080d42000fca8b06391615f83ee665e9c3f38513.tar.gz
Make Travis CI fail if docs have warnings or errors
Now that tox has a job for building the docs, we can add it to the Travis job. Then add the '-W' flag to the Sphinx options, so any warnings are upgraded to errors. Fixes #414.
-rw-r--r--.travis.yml1
-rw-r--r--docs/Makefile2
-rw-r--r--tox.ini2
3 files changed, 3 insertions, 2 deletions
diff --git a/.travis.yml b/.travis.yml
index cbf8fbcd..ecd6215c 100644
--- a/.travis.yml
+++ b/.travis.yml
@@ -23,6 +23,7 @@ env:
- TOXENV=py33
- TOXENV=py34
- TOXENV=gae
+ - TOXENV=docs
# https://github.com/travis-ci/travis-ci/issues/4794
matrix:
include:
diff --git a/docs/Makefile b/docs/Makefile
index 135c543e..66e3ee5e 100644
--- a/docs/Makefile
+++ b/docs/Makefile
@@ -2,7 +2,7 @@
#
# You can set these variables from the command line.
-SPHINXOPTS =
+SPHINXOPTS = '-W'
SPHINXBUILD = sphinx-build
PAPER =
BUILDDIR = _build
diff --git a/tox.ini b/tox.ini
index e8247cf6..ff4875cc 100644
--- a/tox.ini
+++ b/tox.ini
@@ -43,7 +43,7 @@ basepython = python2.7
deps=
-r{toxinidir}/docs/requirements.txt
commands=
- rm -r {toxinidir}/docs/_build
+ rm -rf {toxinidir}/docs/_build
make -C {toxinidir}/docs html
whitelist_externals=
make