summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorCory Benfield <lukasaoz@gmail.com>2016-07-11 09:48:10 +0100
committerCory Benfield <lukasaoz@gmail.com>2016-07-11 09:48:10 +0100
commit9f5454eac808a105307b2d363c99ce97e5109821 (patch)
treef40e0475300ae28f4f4b99c828f4d492e88442b5
parentf620d997134708b09560ca5797aa79a59a2ef4c0 (diff)
downloadurllib3-9f5454eac808a105307b2d363c99ce97e5109821.tar.gz
Have the 'secure' flag install ipaddress.
This is actually strictly not needed: ipaddress is a transient dependency because cryptography requires it. However, it's best not to rely on transient dependencies for things *we* need!
-rw-r--r--setup.py3
1 files changed, 3 insertions, 0 deletions
diff --git a/setup.py b/setup.py
index 3ea33880..1e0eb526 100644
--- a/setup.py
+++ b/setup.py
@@ -59,6 +59,9 @@ setup(name='urllib3',
'pyasn1',
'certifi',
],
+ 'secure:python_version < "3.3"': [
+ "ipaddress",
+ ],
'socks': [
'PySocks>=1.5.6,<2.0',
]