summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorVictor Stinner <victor.stinner@gmail.com>2014-11-13 00:10:59 +0100
committerVictor Stinner <victor.stinner@gmail.com>2014-11-13 00:10:59 +0100
commite1a2bfaa33788784fea4a36cb4750decf9efa200 (patch)
treec6d4866bf1eb85b821cbbbb13a9602c1812351fa
parentaacdee795a99c396af7c99a66cd54808626debfa (diff)
downloadtrollius-e1a2bfaa33788784fea4a36cb4750decf9efa200.tar.gz
set version to 1.0.3
-rw-r--r--doc/changelog.rst25
-rw-r--r--doc/conf.py2
-rw-r--r--setup.py2
3 files changed, 18 insertions, 11 deletions
diff --git a/doc/changelog.rst b/doc/changelog.rst
index 8b92607..cdfb74d 100644
--- a/doc/changelog.rst
+++ b/doc/changelog.rst
@@ -2,6 +2,22 @@
Change log
++++++++++
+Version 1.0.3
+=============
+
+Changes:
+
+* On Python 3.5, windows_utils.socketpair is now an alias to socket.socketpair.
+* Enhance protocol representation: add "closed" or "closing" info.
+* Reuse socket.socketpair() on Windows if available
+* run_forever() now consumes BaseException of the temporary task. If the
+ coroutine raised a BaseException, consume the exception to not log a warning.
+ The caller doesn't have access to the local task.
+* Python issue 22448: cleanup _run_once(), only iterate once to remove delayed
+ calls that were cancelled.
+* Return destructor logs the source traceback in debug mode
+
+
2014-10-02: Version 1.0.2
=========================
@@ -27,15 +43,6 @@ Major bugfixes:
Other changes:
-* On Python 3.5, windows_utils.socketpair is now an alias to socket.socketpair.
-* Enhance protocol representation: add "closed" or "closing" info.
-* Reuse socket.socketpair() on Windows if available
-* run_forever() now consumes BaseException of the temporary task. If the
- coroutine raised a BaseException, consume the exception to not log a warning.
- The caller doesn't have access to the local task.
-* Python issue 22448: cleanup _run_once(), only iterate once to remove delayed
- calls that were cancelled.
-* Return destructor logs the source traceback in debug mode
* Python issue #22448: Improve cancelled timer callback handles cleanup. Patch
by Joshua Moore-Oliva.
* Python issue #22369: Change "context manager protocol" to "context management
diff --git a/doc/conf.py b/doc/conf.py
index 706bf44..bfe2776 100644
--- a/doc/conf.py
+++ b/doc/conf.py
@@ -48,7 +48,7 @@ copyright = u'2014, Victor Stinner'
# built documents.
#
# The short X.Y version.
-version = release = '1.0.2'
+version = release = '1.0.3'
# The language for content autogenerated by Sphinx. Refer to documentation
# for a list of supported languages.
diff --git a/setup.py b/setup.py
index 00e836d..fc37553 100644
--- a/setup.py
+++ b/setup.py
@@ -43,7 +43,7 @@ if sys.version_info < (3,):
install_options = {
"name": "trollius",
- "version": "1.0.2",
+ "version": "1.0.3",
"license": "Apache License 2.0",
"author": 'Victor Stinner',
"author_email": 'victor.stinner@gmail.com',