summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorVictor Stinner <victor.stinner@gmail.com>2014-11-21 00:28:26 +0100
committerVictor Stinner <victor.stinner@gmail.com>2014-11-21 00:28:26 +0100
commit6a9b3f079447ad2961bd9d87c3ba5c3eaaee732a (patch)
tree8fd1f00e8a62721a0ca9f2ef5c4fcfcd17d4168f
parente3156061b3603cc9d09e4e2f2865d138b6871b39 (diff)
downloadtrollius-6a9b3f079447ad2961bd9d87c3ba5c3eaaee732a.tar.gz
update changelog; set version to 1.0.4
-rw-r--r--doc/changelog.rst13
-rw-r--r--doc/conf.py2
-rw-r--r--setup.py2
3 files changed, 15 insertions, 2 deletions
diff --git a/doc/changelog.rst b/doc/changelog.rst
index cce66b5..f584502 100644
--- a/doc/changelog.rst
+++ b/doc/changelog.rst
@@ -2,6 +2,16 @@
Change log
++++++++++
+Version 1.0.4 (development version)
+===================================
+
+Changes:
+
+* BaseSelectorEventLoop.close() now closes the self-pipe before calling the
+ parent close() method. If the event loop is already closed, the self-pipe is
+ not unregistered from the selector.
+
+
2014-10-20: Version 1.0.3
=========================
@@ -31,6 +41,9 @@ Changes:
module: module backported from Python 3.5.
* BaseEventLoop.add_signal_handler() now raises an exception if the parameter
is a coroutine function.
+* Coroutine functions and objects are now rejected with a TypeError by the
+ following functions: add_signal_handler(), call_at(), call_later(),
+ call_soon(), call_soon_threadsafe(), run_in_executor().
2014-10-02: Version 1.0.2
diff --git a/doc/conf.py b/doc/conf.py
index bfe2776..5535a22 100644
--- a/doc/conf.py
+++ b/doc/conf.py
@@ -48,7 +48,7 @@ copyright = u'2014, Victor Stinner'
# built documents.
#
# The short X.Y version.
-version = release = '1.0.3'
+version = release = '1.0.4'
# The language for content autogenerated by Sphinx. Refer to documentation
# for a list of supported languages.
diff --git a/setup.py b/setup.py
index fc37553..2072837 100644
--- a/setup.py
+++ b/setup.py
@@ -43,7 +43,7 @@ if sys.version_info < (3,):
install_options = {
"name": "trollius",
- "version": "1.0.3",
+ "version": "1.0.4",
"license": "Apache License 2.0",
"author": 'Victor Stinner',
"author_email": 'victor.stinner@gmail.com',