summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGuido van Rossum <guido@python.org>2013-10-22 10:33:07 -0700
committerGuido van Rossum <guido@python.org>2013-10-22 10:33:07 -0700
commit16a239f08fe854325b0d8c5a870998d34d4258d2 (patch)
tree31e95e2e5b14f7f358aaa7fcfea892f0efac69bb
parent162c29276541a9231c1a75c04560b5aecf4f0732 (diff)
downloadtrollius-16a239f08fe854325b0d8c5a870998d34d4258d2.tar.gz
Changes by Sonald Stufft to build pypi distros. Yay!0.1.1
-rw-r--r--.hgignore2
-rw-r--r--MANIFEST.in7
-rw-r--r--Makefile7
-rw-r--r--pypi.bat1
-rw-r--r--setup.cfg2
-rw-r--r--setup.py30
6 files changed, 39 insertions, 10 deletions
diff --git a/.hgignore b/.hgignore
index 9987002..6d1136f 100644
--- a/.hgignore
+++ b/.hgignore
@@ -10,3 +10,5 @@ venv$
distribute_setup.py$
distribute-\d+.\d+.\d+.tar.gz$
build$
+dist$
+.*\.egg-info$
diff --git a/MANIFEST.in b/MANIFEST.in
new file mode 100644
index 0000000..317dcc3
--- /dev/null
+++ b/MANIFEST.in
@@ -0,0 +1,7 @@
+include Makefile
+include *.c *.py
+
+recursive-include examples *.py
+recursive-include tests *.crt
+recursive-include tests *.key
+recursive-include tests *.py
diff --git a/Makefile b/Makefile
index ed3caf2..74c38ca 100644
--- a/Makefile
+++ b/Makefile
@@ -30,5 +30,12 @@ clean:
rm -f `find . -type f -name '#*#' `
rm -f `find . -type f -name '*.orig' `
rm -f `find . -type f -name '*.rej' `
+ rm -rf dist
rm -f .coverage
rm -rf htmlcov
+ rm -f MANIFEST
+
+
+# Make distributions for Python 3.3
+pypi: clean
+ python3.3 setup.py sdist upload
diff --git a/pypi.bat b/pypi.bat
new file mode 100644
index 0000000..5218ace
--- /dev/null
+++ b/pypi.bat
@@ -0,0 +1 @@
+c:\Python33\python.exe setup.py bdist_wheel upload
diff --git a/setup.cfg b/setup.cfg
deleted file mode 100644
index 172844c..0000000
--- a/setup.cfg
+++ /dev/null
@@ -1,2 +0,0 @@
-[build_ext]
-build_lib=asyncio
diff --git a/setup.py b/setup.py
index fad16e7..011db09 100644
--- a/setup.py
+++ b/setup.py
@@ -1,14 +1,28 @@
import os
-from distutils.core import setup, Extension
+from setuptools import setup, Extension
extensions = []
if os.name == 'nt':
- ext = Extension('_overlapped', ['overlapped.c'], libraries=['ws2_32'])
+ ext = Extension(
+ 'asyncio._overlapped', ['overlapped.c'], libraries=['ws2_32'],
+ )
extensions.append(ext)
-setup(name='asyncio',
- description="reference implementation of PEP 3156",
- url='http://www.python.org/dev/peps/pep-3156/',
- packages=['asyncio'],
- ext_modules=extensions
- )
+setup(
+ name="asyncio",
+ version="0.1.1",
+
+ description="reference implementation of PEP 3156",
+ long_description=open("README").read(),
+ url="http://www.python.org/dev/peps/pep-3156/",
+
+ classifiers=[
+ "Programming Language :: Python",
+ "Programming Language :: Python :: 3",
+ "Programming Language :: Python :: 3.3",
+ ],
+
+ packages=["asyncio"],
+
+ ext_modules=extensions,
+)