summaryrefslogtreecommitdiff
path: root/setup.py
diff options
context:
space:
mode:
Diffstat (limited to 'setup.py')
-rw-r--r--setup.py91
1 files changed, 19 insertions, 72 deletions
diff --git a/setup.py b/setup.py
index 569ca50..015b7e5 100644
--- a/setup.py
+++ b/setup.py
@@ -1,46 +1,6 @@
-# Prepare a release:
-#
-# - git pull --rebase
-# - fill trollius changelog
-# - run maybe ./update-asyncio-step1.sh
-# - run all tests on Linux: tox
-# - run tests on Windows
-# - test examples
-# - check that "python setup.py sdist" contains all files tracked by
-# the SCM (Mercurial): update MANIFEST.in if needed
-# - run test on Windows: releaser.py test
-# - update version in setup.py (version) and doc/conf.py (version, release)
-# - set release date in doc/changelog.rst
-# - git commit
-# - git push
-#
-# Release a new version:
-#
-# - git tag trollius-VERSION
-# - git push --tags
-# - Remove untracked files/dirs: git clean -fdx
-# - On Linux: python2 setup.py sdist
-# FIXME: don't use bdist_wheel because of
-# FIXME: https://github.com/haypo/trollius/issues/1
-# - twine upload dist/*
-# - On Windows: python releaser.py release
-#
-# After the release:
-#
-# - increment version in setup.py (version) and doc/conf.py (version, release)
-# - git commit -a -m "post release X.Y"
-# - git push
-
import os
import sys
-try:
- from setuptools import setup, Extension
- SETUPTOOLS = True
-except ImportError:
- SETUPTOOLS = False
- # Use distutils.core as a fallback.
- # We won't be able to build the Wheel file on Windows.
- from distutils.core import setup, Extension
+from setuptools import setup, Extension
with open("README.rst") as fp:
long_description = fp.read()
@@ -53,40 +13,27 @@ if os.name == 'nt':
extensions.append(ext)
requirements = ['six']
-if sys.version_info < (2, 7):
- requirements.append('ordereddict')
if sys.version_info < (3,):
requirements.append('futures')
-install_options = {
- "name": "trollius",
- "version": "2.3",
- "license": "Apache License 2.0",
- "author": 'Victor Stinner',
- "author_email": 'victor.stinner@gmail.com',
-
- "description": "Port of the Tulip project (asyncio module, PEP 3156) on Python 2",
- "long_description": long_description,
- "url": "https://github.com/haypo/trollius",
-
- "classifiers": [
+setup(
+ name="trollius",
+ version="2.3",
+ license="Apache License 2.0",
+ author='Victor Stinner',
+ author_email='victor.stinner@gmail.com',
+ description="Deprecated, unmaintained port of the asyncio module (PEP 3156) on Python 2",
+ long_description=long_description,
+ url="https://github.com/jamadden/trollius",
+ classifiers=[
"Programming Language :: Python",
- "Programming Language :: Python :: 3",
+ "Programming Language :: Python :: 2.7",
"License :: OSI Approved :: Apache Software License",
],
-
- "packages": ["trollius"],
- "test_suite": "runtests.runtests",
-
- "ext_modules": extensions,
-}
-if SETUPTOOLS:
- install_options['install_requires'] = requirements
-
-print("!!! WARNING !!! The Trollius project is now deprecated!")
-print("")
-
-setup(**install_options)
-
-print("")
-print("!!! WARNING !!! The Trollius project is now deprecated!")
+ packages=[
+ "trollius",
+ ],
+ ext_modules=extensions,
+ install_requires=requirements,
+ python_requires=">=2.7, < 3",
+)