summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorVictor Stinner <vstinner@redhat.com>2015-07-11 12:03:16 +0200
committerVictor Stinner <vstinner@redhat.com>2015-07-11 12:04:32 +0200
commit53bf283c2966c74f98069f69645ea8a6c616a904 (patch)
tree4b80854f12ae0a11e48008246d3b62dc3fb87565
parent16b46b383ca84dcdc3aecc6ccf735499d497fef0 (diff)
downloadtrollius-git-53bf283c2966c74f98069f69645ea8a6c616a904.tar.gz
don't commit in update-asyncio-step3.sh
update setup.py to use git
-rw-r--r--setup.py11
-rwxr-xr-xupdate-asyncio-step3.sh8
2 files changed, 13 insertions, 6 deletions
diff --git a/setup.py b/setup.py
index c98c975..9ec90cc 100644
--- a/setup.py
+++ b/setup.py
@@ -1,6 +1,6 @@
# Release procedure:
# - fill trollius changelog
-# - run maybe update_tulip.sh
+# - run maybe ./update_asyncio_step1.sh
# - run unit tests with concurrent.futures
# - run unit tests without concurrent.futures
# - run unit tests without ssl: set sys.modules['ssl']=None at startup
@@ -9,13 +9,14 @@
# - set release date in doc/changelog.rst
# - check that "python setup.py sdist" contains all files tracked by
# the SCM (Mercurial): update MANIFEST.in if needed
-# - hg ci
-# - hg tag trollius-VERSION
-# - hg push
+# - git commit
+# - git tag trollius-VERSION
+# - git push --tags
+# - git push
# - On Linux: python setup.py register sdist bdist_wheel upload
# - On Windows: python release.py release
# - increment version in setup.py (version) and doc/conf.py (version, release)
-# - hg ci && hg push
+# - gt commit && git push
import os
import sys
diff --git a/update-asyncio-step3.sh b/update-asyncio-step3.sh
index cdd3208..cc13503 100755
--- a/update-asyncio-step3.sh
+++ b/update-asyncio-step3.sh
@@ -1,4 +1,10 @@
set -e -x
./update-asyncio-step2.sh
tox -e py27,py34
-git commit -m 'Merge asyncio into trollius'
+
+git status
+echo
+echo "Now type:"
+echo "git commit -m 'Merge asyncio into trollius'"
+echo
+echo "You may have to add unstaged files"