summaryrefslogtreecommitdiff
path: root/doc/plugins.txt
diff options
context:
space:
mode:
Diffstat (limited to 'doc/plugins.txt')
-rw-r--r--doc/plugins.txt21
1 files changed, 15 insertions, 6 deletions
diff --git a/doc/plugins.txt b/doc/plugins.txt
index 61e4408..bd3ceda 100644
--- a/doc/plugins.txt
+++ b/doc/plugins.txt
@@ -6,8 +6,9 @@ tox plugins
.. versionadded:: 2.0
With tox-2.0 a few aspects of tox running can be experimentally modified
-by writing hook functions. We expect the list of hook function to grow
-over time.
+by writing hook functions. The list of of available hook function is
+to grow over time on a per-need basis.
+
writing a setuptools entrypoints plugin
---------------------------------------
@@ -30,19 +31,23 @@ Python packaging index::
install_requires=['tox>=2.0'],
)
-You can then install the plugin to develop it via::
+If installed, the ``entry_points`` part will make tox see and integrate
+your plugin during startup.
+
+You can install the plugin for development ("in-place") via::
pip install -e .
-and later publish it.
+and later publish it via something like::
-The ``entry_points`` part allows tox to see your plugin during startup.
+ python setup.py sdist register upload
Writing hook implementations
----------------------------
-A plugin module needs can define one or more hook implementation functions::
+A plugin module defines one or more hook implementation functions
+by decorating them with tox's ``hookimpl`` marker::
from tox import hookimpl
@@ -65,5 +70,9 @@ tox hook specifications
----------------------------
.. automodule:: tox.hookspecs
+
+.. autoclass:: tox.config.Parser
:members:
+.. autoclass:: tox.config.Config
+ :members: