summaryrefslogtreecommitdiff
path: root/doc/example/basic.txt
diff options
context:
space:
mode:
Diffstat (limited to 'doc/example/basic.txt')
-rw-r--r--doc/example/basic.txt5
1 files changed, 4 insertions, 1 deletions
diff --git a/doc/example/basic.txt b/doc/example/basic.txt
index f4df233..d0ad004 100644
--- a/doc/example/basic.txt
+++ b/doc/example/basic.txt
@@ -254,7 +254,10 @@ a test run when ``python setup.py test`` is issued::
#import here, cause outside the eggs aren't loaded
import tox
import shlex
- errno = tox.cmdline(args=shlex.split(self.tox_args))
+ args = self.tox_args
+ if args:
+ args = shlex.split(self.tox_args)
+ errno = tox.cmdline(args=args)
sys.exit(errno)
setup(