summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--CHANGELOG.txt6
-rw-r--r--doc/conf.py4
-rw-r--r--setup.py2
-rw-r--r--tests/test_venv.py4
-rw-r--r--tox/__init__.py2
-rw-r--r--tox/_venv.py4
6 files changed, 18 insertions, 4 deletions
diff --git a/CHANGELOG.txt b/CHANGELOG.txt
index 883603e..087e17c 100644
--- a/CHANGELOG.txt
+++ b/CHANGELOG.txt
@@ -1,3 +1,9 @@
+0.9.dev0
+-----------------
+
+- fix pip-installation mixups by always unsetting PIP_RESPECT_VIRTUALENV
+ (thanks Armin Ronacher)
+
0.8
-----------------
diff --git a/doc/conf.py b/doc/conf.py
index df9a0d9..0221785 100644
--- a/doc/conf.py
+++ b/doc/conf.py
@@ -48,9 +48,9 @@ copyright = u'2010, holger krekel'
# built documents.
#
# The short X.Y version.
-version = '0.8'
+version = '0.9'
# The full version, including alpha/beta/rc tags.
-release = '0.8'
+release = '0.9'
# The language for content autogenerated by Sphinx. Refer to documentation
# for a list of supported languages.
diff --git a/setup.py b/setup.py
index d44b98f..be2c495 100644
--- a/setup.py
+++ b/setup.py
@@ -35,7 +35,7 @@ def main():
description='virtualenv-based automation of test activities',
long_description=long_description,
url='http://codespeak.net/tox',
- version='0.8',
+ version='0.9.dev0',
license='GPLv2 or later',
platforms=['unix', 'linux', 'osx', 'cygwin', 'win32'],
author='holger krekel',
diff --git a/tests/test_venv.py b/tests/test_venv.py
index dc4d931..e8777e7 100644
--- a/tests/test_venv.py
+++ b/tests/test_venv.py
@@ -307,4 +307,8 @@ class TestVenvTest:
py.test.raises(ZeroDivisionError, "venv.easy_install(['qwe'])")
py.test.raises(ZeroDivisionError, "venv.pip_install(['qwe'])")
py.test.raises(ZeroDivisionError, "venv._pcall([1,2,3])")
+ monkeypatch.setenv("PIP_RESPECT_VIRTUALENV", "1")
+ py.test.raises(ZeroDivisionError, "venv.pip_install(['qwe'])")
+ assert 'PIP_RESPECT_VIRTUALENV' not in os.environ
+ os.environ['PIP_RESPECT_VIRTUALENV'] = "1"
diff --git a/tox/__init__.py b/tox/__init__.py
index 05259cc..2053957 100644
--- a/tox/__init__.py
+++ b/tox/__init__.py
@@ -1,5 +1,5 @@
#
-__version__ = "0.8"
+__version__ = "0.9.dev0"
import apipkg
diff --git a/tox/_venv.py b/tox/_venv.py
index 6414407..72ee845 100644
--- a/tox/_venv.py
+++ b/tox/_venv.py
@@ -188,6 +188,10 @@ class VirtualEnv(object):
self.envconfig.downloadcache.ensure(dir=1)
argv.append("--download-cache=%s" %
self.envconfig.downloadcache)
+ try:
+ del os.environ['PIP_RESPECT_VIRTUALENV']
+ except KeyError:
+ pass
self._pcall(argv, cwd=self.envconfig.envlogdir)
def _install(self, args):